poj 3254 Corn Fields

博客围绕农场主John的种植问题展开,他有M×N的牧场,部分方格肥沃可种玉米,且所选方格不能相邻。需计算种植方格的选择方案数。采用状态压缩dp方法,dp[i][j]表示第i行状态为j时的所有可能,通过特定条件判断状态并更新dp值。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:

1 2 3
  4  


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

思路:

状态压缩dp。dp[i][j]表示第i行状态为j时的所有可能。

判断一个状态没有相邻1时用:state & (state << 1) == 0。

从上到下逐行扫描,每次扫描该行的一个状态,然后更新在这个状态下的下面一行的所有状态的dp。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

typedef long long ll;
const int MAXN = 13;
const int MOD = 1e9;
ll dp[MAXN][1 << MAXN];
int n, m;

int infertile[MAXN];

int main()
{
	cin >> m >> n;
    	
	int a;
	memset(dp, 0, sizeof(dp));

	for (int i = 1; i <= m; i++)
	{
		int temp = 0;
		for (int j = 0; j < n; j++)
		{
		    cin >> a;
			if (a == 0)
			{
				temp |= (1 << j);
			}
		}
		infertile[i] = temp;
	}
	infertile[0] = 0;
	dp[0][0] = 1;

	for (int i = 0; i < m; i++)
	{
		for (int j = 0; j < (1 << n); j++)
		{
			if (((j & infertile[i]) == 0) && ((j & (j << 1)) == 0))
			{
				for (int k = 0; k < (1 << n); k++)
				{
					if (((k & infertile[i+1]) == 0) && ((k & (k << 1)) == 0) && ((j & k) == 0))
					{
						dp[i+1][k] = (dp[i+1][k] + dp[i][j]) % MOD;
					}
				}
			}

		}
	}

	ll result = 0;
	for (int i = 0; i < (1 << n); i++)
	{
		result = (result + dp[m][i]) % MOD;
	}

	cout << result << endl;

	return 0;
} 
 

 

内容概要:本文详细介绍了如何使用Matlab对地表水源热泵系统进行建模,并采用粒子群算法来优化每小时的制冷量和制热量。首先,文章解释了地表水源热泵的工作原理及其重要性,随后展示了如何设定基本参数并构建热泵机组的基础模型。接着,文章深入探讨了粒子群算法的具体实现步骤,包括参数设置、粒子初始化、适应度评估以及粒子位置和速度的更新规则。为了确保优化的有效性和实用性,文中还讨论了如何处理实际应用中的约束条件,如设备的最大能力和制冷/制热模式之间的互斥关系。此外,作者分享了一些实用技巧,例如引入混合优化方法以加快收敛速度,以及在目标函数中加入额外的惩罚项来减少不必要的模式切换。最终,通过对优化结果的可视化分析,验证了所提出的方法能够显著降低能耗并提高系统的运行效率。 适用人群:从事暖通空调系统设计、优化及相关领域的工程师和技术人员,尤其是那些希望深入了解地表水源热泵系统特性和优化方法的专业人士。 使用场景及目标:适用于需要对地表水源热泵系统进行精确建模和优化的情景,旨在找到既满足建筑负荷需求又能使机组运行在最高效率点的制冷/制热量组合。主要目标是在保证室内舒适度的前提下,最大限度地节约能源并延长设备使用寿命。 其他说明:文中提供的Matlab代码片段可以帮助读者更好地理解和复现整个建模和优化过程。同时,作者强调了在实际工程项目中灵活调整相关参数的重要性,以便获得更好的优化效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值