E

本文探讨了皮特拥有的初始香烟数量如何通过收集烟蒂来最大化抽烟次数的问题,并提供了一个C语言实现的解决方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
How many cigarettes can Peter have?

Input
Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k.

Output
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.

Sample Input
4 3
10 3
100 5

Sample Output
5
14
124

题目大意:皮特开始有n支烟,k个烟屁股可以换一支新烟,问皮特最多能抽到几只烟

思路:抽完所有烟 —— 换烟 —— 抽完所有烟——换烟。。。直到剩下的烟屁股不够换一支新烟

#include <stdio.h>

int main()
{
    int n,k;
    while (scanf("%d%d",&n,&k) != EOF)
    {
        int sum = n;
        while (n >= k)
        {
            sum += n / k;
            n = (n % k) + (n / k);//换完新烟后再抽完,剩下的烟屁股
        }
        printf("%d\n",sum);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值