Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
How many cigarettes can Peter have?
Input
Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k.
Output
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
Sample Input
4 3
10 3
100 5
Sample Output
5
14
124
题目大意:皮特开始有n支烟,k个烟屁股可以换一支新烟,问皮特最多能抽到几只烟
思路:抽完所有烟 —— 换烟 —— 抽完所有烟——换烟。。。直到剩下的烟屁股不够换一支新烟
#include <stdio.h>
int main()
{
int n,k;
while (scanf("%d%d",&n,&k) != EOF)
{
int sum = n;
while (n >= k)
{
sum += n / k;
n = (n % k) + (n / k);//换完新烟后再抽完,剩下的烟屁股
}
printf("%d\n",sum);
}
return 0;
}