POJ 2115 C Looooops

https://cn.vjudge.net/problem/POJ-2115

题目

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)
  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values $0 \leqslant x < 2^k$) modulo $2^k$.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

题解

写出线性同余方程

\[A+Cx\equiv B \pmod {2^k}\]

整理得

\[Cx\equiv B-A \pmod {2^k}\]

有解的充要条件是$\text{GCD}(C,2^k)\mid{B-A}$

两边同除$\text{GCD}(C,2^k)$,得

\[\frac{C}{g} x\equiv \frac{B-A}{g} \pmod {\frac{2^k}{g}}\]

然后就可以两边同乘以逆元了,得到模$\frac{2^k}{g}$下的唯一解,则模$2^k$下有$g$个解= =

但是题目只要求最小的……

还有一个坑是爆int,在移位的时候一定要用1LL

真的服了,起名llabs还能撞名字= =

AC代码

#include<cstdio>
#include<cstdlib>
#include<cctype>
#include<cstring>
#include<algorithm>
#include<set>
#define REP(r,x,y) for(register int r=(x); r<(y); r++)
#define REPE(r,x,y) for(register int r=(x); r<=(y); r++)
#define PERE(r,x,y) for(register int r=(x); r>=(y); r--)
#ifdef sahdsg
#define DBG(...) printf(__VA_ARGS__),fflush(stdout)
#else
#define DBG(...) (void)0
#endif
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
char ch; int si;

#define gc() getchar()

template<class T>
inline void read(T &x) {
    x=0; si=1; for(ch=gc();!isdigit(ch) && ch!='-';ch=gc());
    if(ch=='-'){si=-1,ch=gc();} for(;isdigit(ch);ch=gc())x=x*10+ch-'0';
    x*=si;
}
template<class T, class...A> inline void read(T &x, A&...a){read(x); read(a...);}

inline LL qmul(LL a, LL b, LL p) {
    LL ans=0;
    for(;b;b>>=1) {
        if(b&1) ans=(ans+a)%p;
        a=(a*2)%p;
    }
    return ans;
}

inline LL GCD(LL a, LL b) {
    return b==0? a:GCD(b,a%b);
}

inline void exgcd(LL a, LL b, LL &x, LL &y) {
    if(b==0) {x=1, y=0; return;}
    exgcd(b,a%b,y,x);
    y-=a/b*x;
    //return d;
}
//inline LL llabs(LL x) {
//    return x<0?-x:x;
//}

int main() {
#ifdef sahdsg
    freopen("in.txt","r",stdin);
#endif
    LL a,b,c,d;
    while(~scanf("%lld%lld%lld%lld", &a, &b, &c, &d) && (a||b||c||d)) {
        d=1LL<<d;
        //ct===b-a mod 1<<k
        b-=a;
        LL g=(GCD(c,d)); DBG("#%lld %lld %lld\n",g, c, d);
        if(b%g) {
            puts("FOREVER");
            continue;
        }
        b/=g, c/=g, d/=g;
        LL x,t;
        exgcd(c,d,x,t);
        b*=x;
        b%=d; if(b<0) b+=d;
        printf("%lld\n", b);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/sahdsg/p/10817208.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值