【树上博弈】 hdu 6105 Gameia

Gameia

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1179    Accepted Submission(s): 505


Problem Description
Alice and Bob are playing a game called 'Gameia ? Gameia !'. The game goes like this :
0. There is a tree with all node unpainted initial.
1. Because Bob is the VIP player, so Bob has K chances to make a small change on the tree any time during the game if he wants, whether before or after Alice's action. These chances can be used together or separate, changes will happen in a flash. each change is defined as cut an edge on the tree.
2. Then the game starts, Alice and Bob take turns to paint an unpainted node, Alice go first, and then Bob.
3. In Alice's move, she can paint an unpainted node into white color.
4. In Bob's move, he can paint an unpainted node into black color, and what's more, all the other nodes which connects with the node directly will be painted or repainted into black color too, even if they are white color before.
5. When anybody can't make a move, the game stop, with all nodes painted of course. If they can find a node with white color, Alice win the game, otherwise Bob.
Given the tree initial, who will win the game if both players play optimally?
 
Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with two integers N and K : the size of the tree and the max small changes that Bob can make.
The next line gives the information of the tree, nodes are marked from 1 to N, node 1 is the root, so the line contains N-1 numbers, the i-th of them give the farther node of the node i+1.
Limits
T≤100
1≤N≤500
0≤K≤500
1≤Pi≤i

Output
For each test case output one line denotes the answer.
If Alice can win, output "Alice" , otherwise "Bob".

Sample Input
2
2 1
1
3 1
1 2

Sample Output
Bob
Alice
 
题意:输入构造一棵树,Bob和Alice涂树上的未涂颜色的节点,alice先涂,bob后涂;alice每次只能涂一个节点为白色,bob可以涂一个节点(未涂色)而且此节点相连的节点(不管是否有色)也涂为黑色。bob还有k次断边的机会!

题解:

  • 如果Bob能把这棵树分成若干两个一组的点对,那么Bob取得胜利,否则Alice获胜。
  • 如果原树不存在两两匹配的方案,Alice从树叶开始,每次都染树叶父节点,Bob被迫只能不断的染叶子,Bob退化成一般玩家,因为Bob做不做小动作都不会逆转局势,总会出现一个时间点Bob没办法跟上Alice的节奏而让Alice染到一个周围都已被染色的孤立点(因为原树不存在两两匹配的方案)
  • 如果原树存在两两匹配的方案,而且Bob的小动作次数也足以把原树分成两两的点对,那么Bob显然获胜。
  • 如果原树存在两两匹配的方案,而Bob的小动作不足以把树分成两两的点对,Alice一定获胜,因为每次染某个叶子节点(该节点为其父节点的唯一子节点),Alice总能迫使Bob不断的做小动作以保证剩下的树不会出现奇数节点的树,且每次小动作割出一个点对(包含Alice刚染的点),最后有两种情况。
  • 出现某个结点有>=2个子节点为叶子节点。Alice染这个点,Bob跟不上Alice的节奏,出现孤点,Ailice取胜
  • 否则整个过程一定会持续到树被染光或者Bob被Alice掏空导致做不了小动作进而被迫割出一块size为奇数的子树(这棵树显然没办法两两匹配)而败北。
  • Bob被允许“任意时刻”做小动作看似很厉害其实很鸡肋,把问题改成“Bob只能在游戏开始之前做小动作”会得到同样的结论。
  • “氪不改命,玄不救非”

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N=550;
int t;
int paint[N+10];
int sonum[N+10],fa[N+10];
int leaf[N+10];

int find_leaf(int n)
{
    int cnt=0;
    for(int i=1; i<=n; i++)
    {
        if(sonum[i]==0)
            leaf[cnt++]=i;
    }
    return cnt;
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(paint,0,sizeof(paint));
        memset(fa,0,sizeof(fa));
        memset(sonum,0,sizeof(sonum));
        memset(leaf,0,sizeof(leaf));
        fa[1]=-1;

        int n,k,x;
        scanf("%d%d",&n,&k);
        for(int i=2; i<=n; i++)
        {
            scanf("%d",&x);
            fa[i]=x;
            sonum[x]++;
        }

        int flag=0,kk=0;
        int cot=find_leaf(n);
//        printf("%d\n",cot);
        for(int i=0; i<cot; i++)
        {
            int tmp=leaf[i];
//            printf("%d\n",fa[tmp]);

            while(tmp!=-1)
            {
                if(!paint[fa[tmp]]&&fa[tmp]!=-1)
                {
                    kk++;
                    paint[tmp]=1;
                    paint[fa[tmp]]=1;
                    tmp=fa[fa[tmp]];
                    if(sonum[tmp]>=2)
                    {
                        sonum[tmp]--;
                        break;
                    }
                }
                else
                {
                    flag=1;
                    break;
                }
            }
            if(flag)
                break;

        }

//        printf("%d %d\n",flag,kk);
        if(kk-1<=k&&!flag)
            printf("Bob\n");
        else
            printf("Alice\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值