Light OJ 1038(概率DP)

Description

Rimi learned a new thing about integers, which is - any positive integer greater than 1 can be divided by its divisors. So, he is now playing with this property. He selects a number N. And he calls this D.

In each turn he randomly chooses a divisor of D (1 to D). Then he divides D by the number to obtain new D. He repeats this procedure until D becomes 1. What is the expected number of moves required for N to become 1.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case begins with an integer N (1 ≤ N ≤ 105).

Output

For each case of input you have to print the case number and the expected value. Errors less than 10-6 will be ignored.

Sample Input

3

1

2

50

Sample Output

Case 1: 0

Case 2: 2.00

Case 3: 3.0333333333


(新人写博客,有错误请及时指出,谢谢)

一道概率dp题

设dp[n]为将n除成1的期望,a[i]是n的第i个约数(默认为从小到大排列),n有m个约数,则有dp[n]=(1+dp[a[1]])/m+(1+dp[a[2]])/m+......+(1+dp[a[m]])/m

由于a[m]==n故有dp[n]=(m+dp[a[m-1]]+dp[a[m-2]]+...dp[a[1]])/(m-1);

不过要注意的是拆n 的约数时要注意i*i是否等于n,若是则只存一个i(想想我就栽在这个点上了QAQ)


代码:


#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<ctype.h>
#include<queue>//堆,队列
#include<stack>//栈
#include<vector>//可变数组
using namespace std;

//这个题我用的是输入一个n就暴力一次,卡时间a了,不过网上都是直接打一个dp表,打表的这个方法更好,被注释掉的部分就是打表代码

const int MAXN=100000+7;
int n,a[MAXN];
double dp[MAXN];
int main()
{
    int T,T1;
    scanf("%d",&T);
    T1=T;

/*
    memset(dp,0,sizeof(dp));
    memset(a,0,sizeof(a));
    dp[1]=0;
    dp[2]=dp[3]=2;
    for(int i=4;i<=MAXN-4;i++)
    {
        double t=2;
        for(int j=2;j*j<=i;j++)
        {
            if(i%j==0)
            {
                if(j*j!=i)t+=2;
                else t+=1;
                dp[i]+=dp[j];
                if(j*j!=i)dp[i]+=dp[i/j];//处理i*i==j的部分
            }
        }

        if(i>1)dp[i]=(dp[i]+t)/(t-1);
    }

*/



    while(T--)
    {
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));

        int total=0;
        for(int i=1;i<=sqrt((double)n);i++)
        {
            if(n%i==0)
            {
                a[total++]=i;
                if(i*i!=n)a[total++]=n/i;//处理i*i==j的部分
            }
        }
        sort(a,a+total);
        for(int i=0;i<total;i++)
        {
            int x=a[i],t=1;
            if(x>1)
            for(int j=0;j<i;j++)
            {
                if(x%a[j]==0)dp[x]+=dp[a[j]],t++;
            }
           //printf("t=%d\n",t);
            if(x>1)dp[x]+=(double)t;
            if(x>1)dp[x]/=(double)(t-1);
        }
        printf("Case %d: %.20f\n",T1-T,dp[n]);
    }
    return 0;
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值