计算机网络基础知识

计算机网络基础知识(持续更新中) 为夯实计算机网络基础知识,本篇跟随b站的胡科大教书匠走进计算机网络的世界,仅记录计算机网络中的重点知识。由于视频中老师的PPT做的非常好,本篇截取了不少视频中的图片,若涉及版权问题请联系作者删除。 阅读详情

1 IP

Internet Protocol,网络之间互连的协议,即为计算机网络相互连接进行通信而设计的协议。任何厂家生产的计算机系统,只要遵守IP协议就可以与因特网互连互通。

UDP与TCP

TCP、UDP 是传输层协议。TCP(Transmission Control Protocol),又叫传输控制协议,UDP(User Datagram Protocol),又叫用户数据报协议。区别如下:

特点TCPUDP
连接性面向连接面向非连接
可靠性可靠不可靠
传输效率慢快

cookie与session

Cookie,有时也用其复数形式 Cookies,指某些网站为了辨别用户身份、进行 session 跟踪而储存在用户本地终端上的数据(通常经过加密)。定义于 RFC2109 和 2965 中的都已废弃,最新取代的规范是 RFC6265 。(可以叫做浏览器缓存)

Session,在计算机中,尤其是在网络应用中,称为“会话控制”。Session 对象存储特定用户会话所需的属性及配置信息。这样,当用户在应用程序的 Web 页之间跳转时,存储在 Session 对象中的变量将不会丢失,而是在整个用户会话中一直存在下去。当用户请求来自应用程序的 Web 页时,如果该用户还没有会话,则 Web 服务器将自动创建一个 Session 对象。当会话过期或被放弃后,服务器将终止该会话。Session 对象最常见的一个用法就是存储用户的首选项。例如,如果用户指明不喜欢查看图形,就可以将该信息存储在 Session 对象中。注意 会话状态仅在支持 cookie 的浏览器中保留。

区别:
1、cookie数据存放在客户的浏览器上,session数据放在服务器上。
2、cookie不是很安全,别人可以分析存放在本地的COOKIE并进行COOKIE欺骗
考虑到安全应当使用session。
3、session会在一定时间内保存在服务器上。当访问增多,会比较占用你服务器的性能
考虑到减轻服务器性能方面,应当使用COOKIE。
4、单个cookie保存的数据不能超过4K,很多浏览器都限制一个站点最多保存20个cookie。
5、一般建议:
将登陆信息等重要信息存放为SESSION
其他信息如果需要保留,可以放在COOKIE中

2 子网掩码

子网掩码(subnet mask)又叫网络掩码、地址掩码、子网络遮罩,它是一种用来指明一个IP地址的哪些位标识的是主机所在的子网,以及哪些位标识的是主机的位掩码。子网掩码不能单独存在,它必须结合IP地址一起使用。子网掩码只有一个作用,就是将某个IP地址划分成网络地址和主机地址两部分。

3 网关

网关(Gateway)又称网间连接器、协议转换器。网关在网络层以上实现网络互连,是最复杂的网络互连设备,仅用于两个高层协议不同的网络互连。网关既可以用于广域网互连,也可以用于局域网互连。网关是一种充当转换重任的计算机系统或设备。使用在不同的通信协议、数据格式或语言,甚至体系结构完全不同的两种系统之间,网关是一个翻译器。与网桥只是简单地传达信息不同,网关对收到的信息要重新打包,以适应目的系统的需求。

4 DNS

Domain Name System,域名系统。万维网上作为域名和IP地址相互映射的一个分布式数据库,能够使用户更方便的访问互联网,而不用去记住能够被机器直接读取的IP数串。

5 HTTP状态码

HTTP状态码(HTTP Status Code)是用以表示网页服务器HTTP响应状态的3位数字代码。它由 RFC 2616 规范定义的,并得到RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。

消息

这一类型的状态码,代表请求已被接受,需要继续处理。这类响应是临时响应,只包含状态行和某些可选的响应头信息,并以空行结束。由于 HTTP/1.0 协议中没有定义任何 1xx 状态码,所以除非在某些试验条件下,服务器禁止向此类客户端发送 1xx 响应。包括100 continue、101 Switching Protocols、102 Processing。

成功

这一类型的状态码,代表请求已成功被服务器接收、理解、并接受。包括200 OK、201 Created、202 Accepted、203 Non-Authoritative Information、204 No Content、205 Reset Content、206 Partial Content、207 Multi-Status。

重定向

这类状态码代表需要客户端采取进一步的操作才能完成请求。通常,这些状态码用来重定向,后续的请求地址(重定向目标)在本次响应的 Location 域中指明。包括300 Multiple Choices、301 Moved Permanently、302 Move temporarily、303 See Other、304 Not Modified、305 Use Proxy、306 Switch Proxy(在最新版的规范中,306状态码已经不再被使用)、307 Temporary Redirect。

请求错误

代表了客户端看起来可能发生了错误,妨碍了服务器的处理。包括400 Bad Request、401 Unauthorized、402 Payment Required(预留)、403 Forbidden、404 Not Found、405 Method Not Allowed、406 Not Acceptable、407 Proxy Authentication Required、408 Request Timeout、409 Conflict、410 Gone、411 Length Required、412 Precondition Failed、413 Request Entity Too Large、414 Request-URI Too Long、415 Unsupported Media Type、416 Requested Range Not Satisfiable、417 Expectation Failed、421 too many connections、422 Unprocessable Entity、423 Locked、424 Failed Dependency、425 Unordered Collection、426 Upgrade Required、449 Retry With、451Unavailable For Legal Reasons。

服务器错误

(5、6开头)代表了服务器在处理请求的过程中有错误或者异常状态发生,也有可能是服务器意识到以当前的软硬件资源无法完成对请求的处理。包括500 Internal Server Error、501 Not Implemented、502 Bad Gateway、503 Service Unavailable、504 Gateway Timeout、505 HTTP Version Not Supported、506 Variant Also Negotiates、507 Insufficient Storage、509 Bandwidth Limit Exceeded、
510 Not Extended、600 Unparseable Response Headers。

6 网络架构

OSI七层模型

Open System Interconnect的缩写,意为开放式系统互联。是一个开放性的通信系统互连参考模型,一个定义得非常好的协议规范。

OSI层功能TCP/IP协议
应用层文件传输、电子邮件、文件服务、虚拟终端TFTP、HTTP、SNMP、FTP、SMTP、DNS、Telnet
表示层数据格式化、代码转换、数据加密–
会话层(Session layer)解除或建立与其他接点的联系–
传输层提供端对端的接口TCP、UDP
网络层为数据包建立路由IP、ICMP、RIP、OSPF、BGP、IGMP
数据链路层传输有地址的帧,错误检测功能SLIP、CSLIP、PPP、ARP、RARP、MTU
物理层以二进制数据形式在物理媒体上传输数据ISO2110、IEEE802、IEEE802.2

TCP/IP五层模型

TCP/IP层网络设备
应用层
传输层四层交换机、也有工作在四层的路由器
网络层路由器、三层交换机
数据链路层网桥(现较少使用)、以太网交换机(二层交换机)、网卡(一半工作在物理层、一半数据链路层)
物理层中继器、集线器、双绞线

TCP/IP四层模型

TCP/IP层结构信息
应用层FTP、TELNET、HTTP、SNMP、TFTP、NTP
传输层TCP、UDP
网络互连层IP
主机到网络层以太网、令牌环网、802.2、802.3
【计算机网络】计算机网络基础知识 计算机网络基础知识博主自述一.计算机网络基础1.计算机网络发展阶段2. 数据通信基础2.1.信息数据概念2.2数据传输类型2.3传输介质2.4数据编码2.5差错控制3.传输网相关技术3.1 传输网的基础概念3.2 广域网相关技术3.3 局域网相关技术3.4宽带域域网相关技术3.5无线个域网相关技术4.TCP/IP4.1网络体系结构 博主自述 此文仅作为计算机基础知识的学习总结,由计算机网络应用技术教程为主要,结合其他相关书籍的部分知识点以及自己的相关看法所总结而成的。本文仅包含基础技术概念,总结不周,还望 阅读详情

相关推荐

【网络入门】详解常用的基础网络知识(笔试面试常考内容)

本文结合多年来的工作实践,来详细讲述一下作为IT从业人员要掌握的一些基础网络知识。

dvlinker的技术专栏 7万+

计算机网络知识汇总(超详细整理)从零基础入门到精通,看完这一篇就够了

为了准备期末考试,同时也是为了之后复习方便,特对计算机网络的知识进行了整理。本篇内容大部分是来源于我们老师上课的ppt。而我根据自己的理解,将老师的PPT整理成博文的形式以便大家复习查阅,同时对于一些不是很清楚的地方,我去查阅了相关资料进行补充,当然也会有少部分个人看法夹带其中来帮助大家理解。应评论要求这里放上本文的思维导图以供大家更好的查看网络边缘:位于互联网边缘与互联网相连的计算机和其他设备,如桌面计算机、移动计算机、服务器、其他智能终端设备网络核心。

leah126的博客 4万+

信奥编程启蒙 3068:【例13.3】时间差

现在给出一个时间,单位是秒,要求按照电子表格式输出,输出保证不会超过 2424 小时。3067:【例13.2】 电子表。把时间转化成电子表格式输出。电子表上的时间显示方法形如。

901

网络基础入门

想学网络,无从下手?快来看这一篇

小白成长之路 1万+

Linux Wireless之80211(nl80211, cfg80211, mac80211)

Linux Wireless之80211(nl80211, cfg80211, mac80211)前言在Linux无线子系统中,cfg80211、mac80211和nl80211是三个关键的组件,它们共同工作以实现对802.11设备的配置和管理。cfg80211负责内核空间的通用API,mac80211负责具体的MAC层实现,而nl80211则作为用户空间与内核空间之间的桥梁,用于配置管理和通信。Netlink 是一个 Linux 中的 socket 类型,用于在内核与用户空间之间传递事件。

DD'Notes 1484

esim分布式云卡池技术

eSIM卡,即Embedded-SIM,嵌入式SIM卡。eSIM卡的概念就是将传统SIM卡直接嵌入到设备芯片上,而不是作为独立的可移除零部件加入设备中,用户无需插入物理SIM卡。这一做法将允许用户更加灵活的选择运营商套餐,或者在无需解锁设备、购买新设备的前提下随时更换运营商。未来通用的eSIM标准建立将为普通消费者、企业用户节省更多移动设备使用成本,并带来更多的便利、安全性。 2018年 3月7日,中国联通宣布,正式在上海、天津、广州、深圳、郑州、长沙6座城市率先启动“eSIM一号双终端”业务的办理。[.

著名博客 3710

计算机网络基础知识(非常详细)从零基础入门到精通,看完这一篇就够了

网络安全行业产业以来,随即新增加了几十个网络安全行业岗位︰网络安全专家、网络安全分析师、安全咨询师、网络安全工程师、安全架构师、安全运维工程师、渗透工程师、信息安全管理员、数据安全工程师、网络安全运营工程师、网络安全应急响应工程师、数据鉴定师、网络安全产品经理、网络安全服务工程师、网络安全培训师、网络安全审计员、威胁情报分析工程师、灾难恢复专业人员、实战攻防专业人员…网上虽然也有很多的学习资源,但基本上都残缺不全的,这是我自己录的网安视频教程,上面路线图的每一个知识点,我都有配套的视频讲解。

leah126的博客 3万+

基于奥比中光Orbbec Astra Pro与ROS实现实时3D环境建模:orb_slam2实战指南

本文提供了一份详细的实战指南,介绍如何使用奥比中光Orbbec Astra Pro深度摄像头与ROS系统,部署并运行ORB-SLAM2算法,实现实时3D环境建模与定位。内容涵盖从驱动安装、环境配置、算法编译到摄像头标定与性能调优的全流程,旨在帮助开发者快速搭建一套高性价比的视觉SLAM系统。

weixin_29054399的博客 337

常用的计算机网络设备有,常用网络设备有哪些,初学者必须要知道的五大网络设备...

在我们接触计算机的同时,网络知识也是必不可少的,搞懂网络我们先要认识这些网络设备,以及它们有什么作用。第一个:路由器(分无线跟有线路由器)如今家用一般都用的无线路由器(俗称WIFI),因为无线路由器都带有线功能,不过大型网络的核心路由器都不用无线的,路由器与其他设备最大的区别是既有WAN口,同时也有LAN口,而交换机的话只有LAN,有些光猫如果带路由功能的话那么它上面一定标有WAN口的。路由器的主...

weixin_30831105的博客 7821

ESP32+LED12864液晶屏实战:手把手教你显示中文与自定义图标(附完整代码)

本文详细介绍了如何使用ESP32单片机驱动带字库的LED12864液晶屏,实现中文显示与自定义图标。从硬件选型、接线方案到驱动编写、字库解析,提供了完整的实战代码与优化技巧,并最终构建了一个智能家居控制面板的完整示例项目。

weixin_29212867的博客 147

西南科技大学模拟电子技术实验二(二极管特性测试及其应用电路)预习报告

3、用二极管正向虚拟IV仪测出数据,并记录数据于虚表3和虚表4。1、按照指导书multisim仿真软件上画出三种模型电路图,1、按照指导书multisim仿真软件上画出三种模型电路图,1、按照指导书multisim仿真软件上画出三种模型电路图,表6 二极管三种模型参数测试表(电源电压=1.2V)2、用万用表测出数据,并记录数据于虚表1和虚表2。2、用万用表测出数据,并记录数据于虚表5和虚表6。表5 二极管三种模型参数测试表(电源电压=12V)二极管三种模型参数测试表(电源电压=12V)

Welcome To My6n Blog 4083

【计算机网络】计算机网络基础知识——万字详解!!!

一计算机网络的基本概念1.1 计算机网络的诞生1.2 计算机网络的定义1.3 因特网的引入二、计算机网络的功能2.1 数据通信2.2 资源共享2.3 分布式处理2.4 提高可靠性2.5 负载均衡三、计算机网络的组成3.1 组成部分3.2 工作方式四、计算机网络的分类4.1 按覆盖范围分类4.2 按使用者分类4.3 按交换技术分类4.4 按拓扑结构分类4.5 按传输技术分类五、计算机网络的性能指标5.1 速率5.2 带宽5.3 吞吐量5.4 时延5.5 时延带宽积5.6 往返时间(RTT)5.7 利用率5.

2302_80127404的博客 1万+

由JavaScript版迷宫游戏引出Java版迷宫地图生成器

Java案例:迷宫地图生成器 一、引入问题 本期18软件1班网页脚本实训项目是完成一个JavaScript版迷宫游戏。 迷宫地图是如何生成的呢?很简单,将一个正方形区域等分为若干行与若干列,比如25行25列,这样就有625个单元格,用一个二维数组map[25][25]就可以保存625个单元格信息,map[i][j] = 1表示该单元格要绘制砖,而map[i][j] = 0表示该单元格不绘制砖。 ...

howard2005的专栏 1473

计算机网络基础知识总结

计算机网络基础知识总结

你是人间四月天 287

《深入浅出多模态》(四):多模态经典模型CLIP

本文为《深入浅出多模态》系列多模态经典模型CLIP,首先从整体介绍多模态模型发展,对其中经典CLIP模型进行详述,从具体论文、数据集、代码、模型结构、结果等角度分析,本专栏适合从事多模态小白及爱好者学习,欢迎大家关注,如有侵权请联系删除!

专注大数据与人工智能技术分享,欢迎私信加群互相学习! 1045

复分析 阿尔福斯(Ahlfors) 第三版答案 英文

答案分为十章,有部分习题没有答案,全英文复分析阿尔福斯(Ahlfors) 第三版答案

计算机网络最基础论文题目,计算机网络基础知识类论文题目 计算机网络基础知识论文题目哪个好...

【100道】关于计算机网络基础知识类论文题目汇总,作为大学生的毕业生应该明白了计算机网络基础知识论文题目哪个好,选一个好的题目后续的计算机网络基础知识论文写作起来会更轻松!一、比较好写的计算机网络基础知识论文题目:1、计算机网络技术(1)计算机网络基本知识2、网络管理员考试同步辅导. 计算机网络基础知识篇3、计算机网络基础知识4、计算机网络基础知识5、计算机网络基础知识(四)6、计算机网络应用基础...

weixin_29085151的博客 459

假人有限元模型

假人模型,车辆碰撞假人有限元模型,适合做乘员安全的研究者利用

关于计算机网络基础知识的网站

知乎: https://zhuanlan.zhihu.com/p/349337101菜鸟教程: https://www.runoob.com/w3cnote/summary-of-network.html 计算机网络基础知识-腾讯云开发者社区-腾讯云

逐梦云间的博客 246

汉书HE8,好用的汇编代码编写工具

汉书HE8,好用的汇编代码编写工具早期编写汇编代码所用功能强大

Data-Structures-and-Algorithm-Analysis-in-Java.pdf

作者: Weiss, Mark A. 出版社: Addison Wesley Data Structures and Algorithm Analysis in Java is an “advanced algorithms” book that fits between traditional CS2 and Algorithms Analysis courses. In the old ACM Curriculum Guidelines, this course was known as CS7. This text is for readers who want to learn good programming and algorithm analysis skills simultaneously so that they can develop such programs with the maximum amo...

计算机网络基础知识学习资料

计算机网络基础知识学习资料 【下载地址】计算机网络基础知识学习资料 本仓库提供了一份详尽的《计算机网络基础知识.pdf》文档,是学习网络基础知识的理想选择。文档从基本概念入手,逐步深入讲解网络原理,内容详尽且实例丰富,帮助读者快速掌握核心知识。图文结合的方式使复杂的网络结构和协议变得直观易懂,适合初学者和进阶者使用。文档...

gitblog_06764的博客 380

探索计算机网络世界的基石:计算机网络基础知识学习资料

探索计算机网络世界的基石:计算机网络基础知识学习资料 【下载地址】计算机网络基础知识学习资料 本仓库提供了一份详尽的《计算机网络基础知识.pdf》文档,是学习网络基础知识的理想选择。文档从基本概念入手,逐步深入讲解网络原理,内容详尽且实例丰富,帮助读者快速掌握核心知识。图文结合的方式使复杂的网络结构和协议变得直观易懂,适...

gitblog_06758的博客 322
上一篇: sql函数基础及应用
下一篇: OpenGL学习记录
anneCoder
博客等级 码龄9年 93粉丝 91原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

个

红包个数最小为10个

元

红包金额最低5元

当前余额3.43元 前往充值 >
需支付:10.00元
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

anneCoder

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值