Largest prime factor
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6803 Accepted Submission(s): 2078
Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
Input
Each line will contain one integer n(0 < n < 1000000).
Output
Output the LPF(n).
Sample Input
1
2
3
4
5
Sample Output
0
1
2
1
3
题目大意求num的最大质因数是在素数表里的排名,本来以为自己的很优化了,结果别人直接用筛选法,把所有数的最大质因数放到相应的数组里。惭愧惭愧!!!
//最大质因数
#include <iostream>
using namespace std;
const int maxn = 1000000+5;
int a[maxn];
int main()
{
int ans = 0;
for (int i = 2; i < maxn; i++)
{
if (!a[i])
{
ans++;
for (int j = i; j < maxn; j += i)
a[j] = ans;
}
}
int n;
while(scanf("%d",&n) == 1)
{
printf("%d\n",a[n]);
}
return 0;
}