基础训练
Who's in the Middle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4184 Accepted Submission(s): 1543
Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input
-
Line 1: A single integer N
-
Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
Output
- Line 1: A single integer that is the median milk output.
Sample Input
5
2
4
1
3
5
Sample Output
3
Hint
INPUT DETAILS:
Five cows with milk outputs of 1..5
OUTPUT DETAILS:
1 and 2 are below 3; 4 and 5 are above 3.
解题思路
:先排序,照中位数
用到算法中的函数sort
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int main()
{
vector<int> v;
int n = 0;
while (scanf("%d",&n) == 1)
{
v.resize(n);
for (int i = 0; i < n; ++i)
{
scanf("%d",&v[i]);
}
sort(v.begin(),v.end());
printf("%d\n",v[(v.size()+1) / 2 - 1]);
v.clear();
}
return 0;
}
Ignatius and the Princess IV
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 32290 Accepted Submission(s): 13919
Problem Description
“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.
“But what is the characteristic of the special integer?” Ignatius asks.
“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.
Can you find the special integer for Ignatius?
Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.Output
For each test case, you have to output only one line which contains the special number you have found.Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1Sample Output
3
5
1
解题思路,使用STL的map
存储数据,将map中的second
当作计数器,若插入不成功
(即map中存在key值),insert返回一个迭代器
(iterator)指向当前map中的pair
结构体,该结构体有两个数据,分别是first和second,我们将second当作计数器,即该key值出现的次数,最后遍历一遍找到map中最大的second对应的key。
#include <iostream>
#include <algorithm>
#include <map>
using namespace std;
int main()
{
map<int,int> mp;
size_t n = 0;
while(scanf("%d",&n) == 1)
{
int num = 1;
int value = 0;
int max = 0;
int spnum = 0;
for (int i = 0; i < n; ++i)
{
scanf("%d",&value);
if (! mp.insert(make_pair(value,num)).second )
mp[value]++;
}
map<int,int>::iterator it = mp.begin();
for (;it != mp.end();++it)
{
if(it->second > max)
{
max = it->second;
spnum = it->first;
}
}
printf("%d\n",spnum);
mp.clear();
}
return 0;
}