HDOJ Accepted Necklace

本文深入探讨了AI音视频处理领域中的视频分割与语义识别技术,介绍了其在自动驾驶、AR增强现实等场景的应用,以及如何通过深度学习实现精准的视频分析。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

 

Accepted Necklace

http://acm.hdu.edu.cn/diy/contest_showproblem.php?cid=12573&pid=1006

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 4
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.

Input

The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.

Output

For each case, output the highest possible value of the necklace.

Sample Input

1 
2 1 
1 1 
1 1 
3 

Sample Output

1 

Source

HDU男生专场公开赛——赶在女生之前先过节(From WHU)
 
这题主要考虑当前状态,否则会超时的。
 

#include<iostream>
using namespace std;
int visited[25],weight[25],value[25];
int N,K,W;
int maxval; //最优解
void dfs(int p,int num,int val,int wei ){ //p表示当前状态,初始化是1 
     if(num==K)
        if(val>maxval)
           maxval=val;
     for(int i=p;i<=N;i++){
         if(!visited[i]){
              if((num+1)<=K && (wei+weight[i])<=W ){  //这一步剪枝
                  visited[i]=1;
                  dfs(i+1,num+1,val+value[i],wei+weight[i]);
                  visited[i]=0;              
              }                                      
         }                
     }       
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
      maxval=0;
      scanf("%d%d",&N,&K);
      for(int i=1;i<=N;i++)
          visited[i]=0,scanf("%d%d",&value[i],&weight[i]);
      scanf("%d",&W);
      dfs(1,0,0,0);
      printf("%d\n",maxval);   
    }
    return 0;
}


 

 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值