Hie with the Pie POJ - 3311

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output
8

先用Floyd算法,求出两点间的最短距离,再用状态压缩dp
用Floyd求出的两点距离,可能是经由中间点的,也可能是两点之间的直接距离
状态压缩dp[s][u],s代表已经选择的集合,u代表当前所选择点
题目要求送餐的话,就必须经过所有点,所以所求是dp[(1<<n)-1][i]+a[i][0]的最小值;
#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
const int M = 1<<11 + 10;
const int inf = 1e9;
int dp[M][12],a[12][12];
int main()
{
    int n;
    while(scanf("%d",&n) != EOF && n)
    {
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= n; j++)
                scanf("%d",&a[i][j]);
        for(int k = 0; k <= n; k++)
            for(int i = 0; i <= n; i++)
                for(int j = 0; j <= n; j++)
                    if(a[i][j] > a[i][k]+a[k][j])
                    a[i][j] = a[i][k]+a[k][j];
        for(int i = 0; i < 1<<n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(i&(1<<j-1))
                {
                    if(i==(1<<j-1))
                        dp[i][j] = a[0][j];  //只经过一个城市时
                    else
                    {
                        dp[i][j] = inf;
                        for(int k = 1; k <= n; k++)
                        {
                            if(j!=k && (i&(1<<k-1)))
                            {
                                dp[i][j] = min(dp[i][j],dp[i^(1<<j-1)][k]+a[k][j]);
                            }
                        }
                    }

                }
            }
        }
        long long ans;
        ans = (dp[(1<<n)-1][1]+a[1][0]);   //回到出发点
        for(int i = 2; i <= n; i++)
            if(ans > dp[(1<<n)-1][i]+a[i][0])
            ans = dp[(1<<n)-1][i]+a[i][0];
        printf("%d\n",ans);
        }

    return 0;
}

OOOooooohhhaa

转载于:https://www.cnblogs.com/lwsh123k/p/9451671.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值