题目:
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
Sample Output
5
题意:
一棵上下级关系树,直接上司不能和下属一起出席,每人都有权值,求出席party的人价值和最大值。
思路:
用dp数据来记录价值,开数组用下标记录去或者不去、
则状态转移方程为:
DP[i][1] += DP[j][0],
DP[i][0] += max{DP[j][0],DP[j][1]};
其中j为i的孩子节点。
这样,从根节点r进行dfs,最后结果为max{DP[r][0],DP[r][1]}。
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[6010],vis[6010],n,dp[6010][2],s[6010];
void dfs(int a)
{
vis[a]=1;
for(int i=1; i<=n; i++)
{
if(vis[i]==0&&f[i]==a)
{
dfs(i);
dp[a][0]+=max(dp[i][0],dp[i][1]);
dp[a][1]+=dp[i][0];
}
}
return;
}
int main()
{
while(~scanf("%d",&n))
{
int a,b;
memset(vis,0,sizeof(vis));
memset(s,0,sizeof(s));
for(int i=1; i<=n; i++)
{
scanf("%d",&dp[i][1]);
dp[i][0]=0;
}
while(scanf("%d%d",&a,&b)&&(a||b))
{
f[a]=b;
s[a]=1;
}
for(int i=1; i<=n; i++)
if(!s[i])a=i;
dfs(a);
printf("%d\n",max(dp[a][0],dp[a][1]));
}
return 0;
}