PAT——1064 Complete Binary Search Tree (30 分)(完全二叉搜索树)

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4
  • 完全二叉搜索树的中序遍历结果就是从小到大排序序列。
  • 对于完全二叉搜索树的根的编号X,其左子树的编号为2X,右子树的编号为2X+1

#include <iostream>
#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;

int n;
int in_order[1001];
int cbt[1001];
int len = 0;

void input()
{
    cin >> n;
    for(int i = 0; i < n; i++)
        cin >> in_order[i];
}

void inorder(int x)
{
    if(x > n)
    {
        return;
    }
    inorder(2 * x);
    cbt[x] = in_order[len++];
    inorder(2 * x + 1);
}

int main()
{
    /*1043 Is It a Binary Search Tree (25 分)*/
    #ifndef ONLINE_JUDGE
        freopen("test.txt", "r", stdin);
    #endif // ONLINE_JUDGE
    input();
    sort(in_order, in_order+n);/*求出中序序列*/

    inorder(1);

    cout << cbt[1];
    for(int i = 2; i <= n; i++)
    {
        cout <<" "<<cbt[i];
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值