Description
Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries.

Input
In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 2
31 - 1).
Output
There are N lines in total, the i-th of which contains the answer for the i-th query.
Sample Input
2 8 10
Sample Output
1 159 11
/*
lowbit(x)为x的二进制表达式中最右边的1所对应的值,比如38288的二进制是1001010110010000
所以lowbit(38288)=16.lowbit(x)=x&-x.因为计算机里的整数采用补码表示,因此-x实际上是x按位取反
末尾+1的结果。
树状数组中,对于节点i.如果他是左子节点,那么父节点就是i+lowbit(i).
如果是右节点,那么父节点就是i-lowbit(i);
*/
#include <iostream>
#include <cstdio>
using namespace std;
int lowb(int x)
{
return x&-x;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
int m=n;
int min,max;
while(lowb(n)/2)
{
min=n-lowb(n)/2;
n=n-lowb(n)/2;
}
while(lowb(m)/2)
{
max=m+lowb(m)/2;
m=m+lowb(m)/2;
}
printf("%d %d\n",n,m);
}
return 0;
}