Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
Sample Input
3 3 1 2 2 3 3 1 3 3 1 2 2 3 3 2 0 0
Sample Output
Yes No
#include <iostream>
#include <string>
#include <cstring>
#include <vector>
#include <cstdio>
using namespace std;
#define maxn 10008
bool val[maxn];
vector <int> ans[10008];
void dfs(int u)
{
val[u]=1;
int len=ans[u].size();
for(int i=0;i<len;i++)
{
if(!val[ans[u][i]])
{
dfs(ans[u][i]);
}
}
}
int main()
{
int n,m,a,b;
while(cin>>n>>m&&n)
{
for(int i=1;i<maxn;i++)
{
ans[i].clear();
}
for(int i=1;i<=m;i++)
{
cin>>a>>b;
ans[a].push_back(b);
}
bool flag=true;
for(int i=1;i<=n;i++)
{
memset(val,0,sizeof(val));
dfs(i);
for(int j=1;j<=n;j++)
{
if(!val[j])
{
flag=false;
goto L;
}
}
}
L:
if(flag)cout<<"Yes"<<endl;
else cout<<"No"<<endl;
}
return 0;
}