题意:给你n个房间,每个房间给你一个灯泡数,再给你每天可以增加的新灯泡数m,你每次都要从左到右全都更新一遍,更新方法是:如果手中的灯泡个数大于等于房间的灯泡个数就更新这个房间,然后继续向下,否则就跳过,再继续往下。然后给你q个询问,问你第几天的情况:更新完的房间数,手中剩余的灯泡数。
During tea-drinking, princess, amongst other things, asked why has such a good-natured and cute Dragon imprisoned Lpl in the Castle? Dragon smiled enigmatically and answered that it is a big secret. After a pause, Dragon added:
— We have a contract. A rental agreement. He always works all day long. He likes silence. Besides that, there are many more advantages of living here in the Castle. Say, it is easy to justify a missed call: a phone ring can't reach the other side of the Castle from where the phone has been left. So, the imprisonment is just a tale. Actually, he thinks about everything. He is smart. For instance, he started replacing incandescent lamps with energy-saving lamps in the whole Castle...
Lpl chose a model of energy-saving lamps and started the replacement as described below. He numbered all rooms in the Castle and counted how many lamps in each room he needs to replace.
At the beginning of each month, Lpl buys mmm energy-saving lamps and replaces lamps in rooms according to his list. He starts from the first room in his list. If the lamps in this room are not replaced yet and Lpl has enough energy-saving lamps to replace all lamps, then he replaces all ones and takes the room out from the list. Otherwise, he'll just skip it and check the next room in his list. This process repeats until he has no energy-saving lamps or he has checked all rooms in his list. If he still has some energy-saving lamps after he has checked all rooms in his list, he'll save the rest of energy-saving lamps for the next month.
As soon as all the work is done, he ceases buying new lamps. They are very high quality and have a very long-life cycle.
Your task is for a given number of month and descriptions of rooms to compute in how many rooms the old lamps will be replaced with energy-saving ones and how many energy-saving lamps will remain by the end of each month.
Input
Each input will consist of a single test case.
The first line contains integers nnn and m(1≤n≤100000,1≤m≤100)m (1 \le n \le 100000, 1 \le m \le 100)m(1≤n≤100000,1≤m≤100) — the number of rooms in the Castle and the number of energy-saving lamps, which Lpl buys monthly.
The second line contains nnn integers k1,k2,...,knk_1, k_2, ..., k_nk1,k2,...,kn
(1≤kj≤10000,j=1,2,...,n)(1 \le k_j \le 10000, j = 1, 2, ..., n)(1≤kj≤10000,j=1,2,...,n) — the number of lamps in the rooms of the Castle. The number in position jjj is the number of lamps in jjj-th room. Room numbers are given in accordance with Lpl's list.
The third line contains one integer q(1≤q≤100000)q (1 \le q \le 100000)q(1≤q≤100000) — the number of queries.
The fourth line contains qqq integers d1,d2,...,dqd_1, d_2, ..., d_qd1,d2,...,dq
(1≤dp≤100000,p=1,2,...,q)(1 \le d_p \le 100000, p = 1, 2, ..., q)(1≤dp≤100000,p=1,2,...,q) — numbers of months, in which queries are formed.
Months are numbered starting with 111; at the beginning of the first month Lpl buys the first m energy-saving lamps.
Output
Print qqq lines.
Line ppp contains two integers — the number of rooms, in which all old lamps are replaced already, and the number of remaining energy-saving lamps by the end of dpd_pdp month.
Hint
Explanation for the sample:
In the first month, he bought 444 energy-saving lamps and he replaced the first room in his list and remove it. And then he had 111 energy-saving lamps and skipped all rooms next. So, the answer for the first month is 1,1−−−−−−11,1------11,1−−−−−−1 room's lamps were replaced already, 111 energy-saving lamp remain.
样例输入复制
5 4
3 10 5 2 7
10
5 1 4 8 7 2 3 6 4 7
样例输出复制
4 0
1 1
3 6
5 1
5 1
2 0
3 2
4 4
3 6
5 1
思路:用线段树来维护每个区间的最小值,如果某次更新完后房间内的待更新灯泡数变为零,那么不在考虑此房间,这样每次查找符合条件的房间就只需要O(logn)的时间,还要注意如果可以要尽量从左儿子开始更新,因为题意是从左向右更新!
代码:
#include <cstdio>
#include <algorithm>
using namespace std;
struct Node
{
int l,r,rt,v;
}a[1008611];
struct Node1
{
int l,r;
}b[1008611];
int ans1=0,ans2,cou;
void push_up(int rt)
{
if(a[rt*2].v!=0&&a[rt*2+1].v!=0)
a[rt].v=min(a[rt*2].v,a[rt*2+1].v);
else if(a[rt*2].v==0&&a[rt*2+1].v!=0)
{
a[rt].v=a[rt*2+1].v;
}
else if(a[rt*2+1].v==0&&a[rt*2].v!=0)
{
a[rt].v=a[rt*2].v;
}
else if(a[rt*2+1].v==0&&a[rt*2].v==0)
{
a[rt].v=0;
}
}
void build(int rt,int l,int r)
{
a[rt].l=l;
a[rt].r=r;
int m=(l+r)/2;
if(l==r)
{
scanf("%d",&a[rt].v);
return;
}
build(rt*2,l,m);
build(rt*2+1,m+1,r);
push_up(rt);
}
void update(int rt)
{
int m=(a[rt].l+a[rt].r)/2;
if(a[rt].l==a[rt].r)
{
ans2-=a[rt].v;
a[rt].v=0;
cou++;
ans1++;
return;
}
if(ans2>=a[rt].v&&a[rt].v!=0)
{
if(ans2>=a[rt*2].v&&a[rt*2].v!=0)
update(rt*2);
else if(ans2>=a[rt*2+1].v)
{
update(rt*2+1);
}
push_up(rt);
}
}
int main()
{
int n,m;
scanf("%d%d",&n,&m);
ans2=m;
int i,k=1;
build(1,1,n);
while(cou<n)
{
while(ans2>=a[1].v&&a[1].v!=0)
{
update(1);
}
if(ans2>=a[1].v)
{
b[k].l=ans1;
b[k++].r=ans2;
ans2+=m;
}
while(ans2<a[1].v)
{
b[k].l=ans1;
b[k++].r=ans2;
ans2+=m;
}
}
int mm;
scanf("%d",&mm);
for(i=1;i<=mm;i++)
{
int t;
scanf("%d",&t);
if(t>=k)
printf("%d %d\n",b[k-1].l,b[k-1].r);
else
printf("%d %d\n",b[t].l,b[t].r);
}
return 0;
}
线段树能做的事还是很多的,一种很强大的数据结构!似乎只要是对连续的区间进行处理都有可能用到线段树。