HDU/HDOJ 1016 简单dfs

针对 PrimeRing 问题,本文详细介绍了如何使用深度优先搜索(DFS)结合有效的剪枝策略来解决这一经典问题。通过筛选素数和限制无效的搜索路径,有效提升了算法效率。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46409    Accepted Submission(s): 20500


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1241  1312  1026  1240  1372 
 


题意很简单,dfs思路也很直接,但仍然TLE了两发,下面讲解剪枝思路:

1.因为题目只要求是以“1”开头,所以我们可以直接把1填入结果数组ans里面,从初始深度为1开始搜索。

2.因为任意两个相邻数和为质数,所以枚举时可以加个判断,若当前枚举数与结果数组前一个的和不为素数,则直接枚举下一个。

3.为了进一步减少时间,所以可以加个素数筛得到素数。


#include <bits/stdc++.h>
using namespace std;

int vis[25],ans[25],n,dp[1001];

void init(void){
	memset(dp,0,sizeof(dp));
	int i,j;
	dp[0] = dp[1] = 1;
	for(i=2 ;i<1001 ;i++){
		if(!dp[i]){
			for(j=2 ;i*j<1001 ;j++){
				dp[i*j] = 1;
			}
		}
	}
}

bool check(int* a){
	int i;
	if(dp[a[0] + a[n-1]])
		return false;
	return true;
}

void output(int* a){
	int i;
	printf("%d",a[0]);
	for(i=1 ;i<n ;i++){
		printf(" %d",a[i]);
	}
	printf("\n");
}

void dfs(int deepth){
	int i;
	if(deepth == n){
		if(check(ans)){
			output(ans);	
		}
		return;
	}
	for(i=2 ;i<=n ;i++){
		if(!vis[i]){
			if(dp[i+ans[deepth-1]])
				continue;
			ans[deepth] = i;
			vis[i] = 1;
			dfs(deepth+1);
			vis[i] = 0;
		}
	}
}

int main(){
	int _=1;
	init();
	while(scanf("%d",&n) != EOF){
		memset(vis,0,sizeof(vis));
		memset(ans,0,sizeof(ans));
		ans[0] = 1;
		printf("Case %d:\n",_++);
		dfs(1);
		printf("\n");
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值