【線段樹】Count the Colors

Painting some colored segments on a line, some previously painted
segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can
see at last.


Input

The first line of each data set contains exactly one integer n,
1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative
integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the
segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all
integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can
be seen from the top, following the count of the segments of
this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1
一道線段樹的入門題。

先維護出所有點的顏色(方法見Mayer's Posters),再進行統計。
詳細細節見程序注釋。

Accode:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <bitset>

const char fi[] = "zoj1610.in";
const char fo[] = "zoj1610.out";
const int maxN = 8010;
const int MAX = 0x3fffff00;
const int MIN = -MAX;

struct SegTree {int L, R, lc, rc, col; };
SegTree tree[maxN << 2];
int col[maxN];
int cnt[maxN];
int L[maxN], R[maxN];
int n, m, tot, N;

  void init_file()
  {
    freopen(fi, "r", stdin);
    freopen(fo, "w", stdout);
  }
  
  void Build(int L, int R)
  {
    int Now = ++tot;
    tree[Now].L = L;
    tree[Now].R = R;
    tree[Now].col = -1;
    int Mid = (L + R) >> 1;
    if (L + 1 < R)
    {
      tree[Now].lc = tot + 1;
      Build(L, Mid);
      tree[Now].rc = tot + 1;
      Build(Mid, R);
    }
  }
  
  void insert(int Now, int i)
  {
    if (tree[Now].col == col[i]) return;
    if (L[i] <= tree[Now].L && R[i] >= tree[Now].R)
      {tree[Now].col = col[i]; return; }
    if (tree[Now].col > -2)
    {
      tree[tree[Now].lc].col =
        tree[tree[Now].rc].col =
        tree[Now].col;
      tree[Now].col = -2;
    }
    int Mid = (tree[Now].L + tree[Now].R) >> 1;
    if (L[i] < Mid) insert(tree[Now].lc, i);
    if (Mid < R[i]) insert(tree[Now].rc, i);
    if (tree[tree[Now].lc].col > -2
      && tree[tree[Now].rc].col > -2
      && tree[tree[Now].lc].col
      == tree[tree[Now].rc].col)
      tree[Now].col = tree[tree[Now].lc].col;
	//注意最後經染色可能把整個線段染成同種顏色,
	//所以這裡維護一下標記。
  }
  
  void count(int Now)
  {
    if (tree[Now].col == -1) return;
    if (tree[Now].col > -1)
    {
      col[tree[Now].L + 1] = tree[Now].col;
      if (col[tree[Now].R + 1] < -1)
        col[tree[Now].R + 1] = -1;
    }	//用一個近似離散化的操作,
	//對每條線段的起始和結尾作上標記,
	//LR都加一是為了防止0下標,方便統計。
    if (tree[Now].col < -1)
    {
      count(tree[Now].lc);
      count(tree[Now].rc);
    } //為多色則二分統計。
  }
  
  void work()
  {
    while (scanf("%d", &n) != EOF)
    {
      tot = 0;
      Build(0, maxN - 1);
      N = 0;
      for (int i = 1; i < n + 1; ++i)
      {
        scanf("%d%d%d", L + i, R + i, col + i);
        N = std::max(col[i], N);
        insert(1, i);
      }
      memset(col, 0xfe, sizeof(col));
	//先把所有點的顏色賦為一個不可能的值。
      memset(cnt, 0, sizeof(cnt));
      count(1);
      int Last = -1;
      for (int i = 1; i < maxN; ++i)
       if (col[i] > -2)
        {
          if (col[i] > -1 && col[i] != Last)
            ++cnt[col[i]];
	//有色且與上一段不重複則統計。
          Last = col[i];
        }
      for (int i = 0; i < N + 1; ++i)
        if (cnt[i]) printf("%d %d\n", i, cnt[i]);
      printf("\n");
    }
  }
  
int main()
{
  init_file();
  work();
  exit(0);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值