约瑟夫问题
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
n个人想玩残酷的死亡游戏,游戏规则如下:
n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。
请输出最后一个人的编号。
n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。
请输出最后一个人的编号。
Input
输入n和m值。
Output
输出胜利者的编号。
Example Input
5 3
Example Output
4
Hint
第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀
代码如下:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int num;
struct node *next;
};
struct node *creat(int n)
{
int i;
struct node *head,*p,*q;
p=(struct node *)malloc(sizeof(struct node));
p->num=1;
p->next=NULL;
head=p;
q=p;
for(i=2; i<=n; i++)
{
p=(struct node *)malloc(sizeof(struct node));
p->num=i;
q->next=p;
q=p;
p->next=NULL;
}
q->next=head;
return head;
}
int sel(struct node *head,int m,int n)
{
int num=0;
struct node *p,*q;
q=head;
while(q->next!=head)
{
q=q->next;
}
while(q->next!=q)
{
p=q->next;
num++;
if(num%m==0)
{
q->next=p->next;
free(p);
}
else
q=p;
}
return q->num;
}
int main()
{
int n,m;
struct node *head;
scanf("%d%d",&n,&m);
head=creat(n);
printf("%d\n",sel(head,m,n));
return 0;
}