PAT A1052 Linked List Sorting (25分)

PAT A1052 Linked List Sorting (25分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<10^​5) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10^​5​​ , 10^​5​​ ], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意:第一行给出节点个数你,以及首地址,接下来n行给出那个结点的地址,数据,下一结点的地址,输出要求按照结点数据从小到大排列,改变结点的地址链接成新的链表。
解析:题目是对静态链表的使用,设置一个结构体包括 address,data,next,以及设置一个flag;
这里需要注意的是
1、题目可能给出无效结点,因此需要flag来判断有效结点和无效结点
2、如果给出的首结点是空的,要直接输出“0 -1”;
3、输出时最后一个结点要单独输出,因为结点地址格式是“%05d”,如果地址是-1,输出会变成-0001

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 100010;
struct Node
{
	int address;
	int data;
	int next;
	int flag;//有可能存在无效结点,因此需要flag该判断
}node[maxn];
bool cmp(Node a, Node b)
{
	if (a.flag == 0||b.flag==0)//如果结点是无效结点则排后
	{
		return a.flag > b.flag;
	}
	else
	{
		return a.data < b.data;
	}
}
int main()
{
	int n, ad;
	cin >> n >> ad;
	for (int i = 0; i < maxn; i++)
	{
		node[i].flag = 0;
	}
	int address;
	for (int i = 0; i < n; i++)
	{
		cin >> address;
		cin >> node[address].data >> node[address].next;
		node[address].address = address;
	}
	int p, count = 0;
	for (p = ad; p != -1; p = node[p].next)
	{
		node[p].flag = 1;
		count++;
	}
	if (count == 0)//特殊情况直接输出返回
	{
		cout << "0 -1" << endl;
		return 0;
	}
	sort(node, node + maxn, cmp);
	for (int i = 0; i < count - 1; i++)
	{
		node[i].next = node[i + 1].address;
	}
	node[count-1].next = -1;
	cout << count << " ";
	printf("%05d\n", node[0].address);
	for (int i = 0; i < count-1; i++)
	{
		printf("%05d %d %05d\n", node[i].address, node[i].data, node[i].next);
	}
	printf("%05d %d %d\n", node[count - 1].address, node[count - 1].data, node[count - 1].next);
	return 0;
}
内容概要:本文介绍了一种利用遗传算法优化BP神经网络进行回归预测的方法,并提供了完整的MATLAB程序代码。主要内容包括数据预处理、遗传算法与BP神经网络的结合、适应度函数的设计以及最终的预测结果展示。文中详细解释了如何将Excel格式的数据导入MATLAB并进行归一化处理,如何定义适应度函数来优化BP神经网络的参数(如激活函数和学习率),并通过遗传算法找到最优解。实验结果显示,在某工业数据集上,经过遗传算法优化后的BP神经网络预测精度显著提高,从原来的0.82提升到了0.91。此外,还提到了一些实用技巧,比如调整遗传代数、修改激活函数等方法进一步改进模型性能。 适合人群:对机器学习有一定了解的研究人员和技术爱好者,特别是那些希望深入了解遗传算法与BP神经网络结合应用的人士。 使用场景及目标:适用于需要快速构建高效回归预测模型的场景,尤其是当传统BP神经网络无法达到预期效果时。通过本篇文章的学习,读者能够掌握一种有效的优化手段,从而提高模型的泛化能力和预测准确性。 其他说明:代码可以直接应用于新的数据集,只需确保数据格式符合要求(Excel格式)。对于想要深入探索或改进现有模型的人来说,还可以尝试更换不同的激活函数或其他调节方式来获得更好的表现。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

VictorierJwr

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值