A1032 Sharing (25分)
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).
Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10^5 ), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next
whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.
Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
题目大意:给出两个链表的首地址以及个数n,接下来n行分别为结点的地址、数据、以及下一个结点的地址,裘两个链表第一个共用结点的地址,如果没有返回-1;
这里给出的地址范围小,因此可以使用静态链表记录,在静态链表的结构体中设置一个flag变量来标记第二个链表是否在第一个链表中出现
代码:
#include <cstdio>
#include <iostream>
using namespace std;
const int maxn = 100010;
struct Node
{
char data;//数据域
int next;//指针域
int flag;//标记
}node[maxn];
int main()
{
int ad1, ad2, n;
cin >> ad1 >> ad2 >> n;
int ad, next;
char data;
for (int i = 0; i < maxn; i++)//初始化链表中flag
{
node[i].flag = 0;
}
for (int i = 0; i < n; i++)//输入数据
{
cin >> ad >> data >> next;
node[ad].data = data;
node[ad].next = next;
}
int p;
for (p = ad1; p != -1; p = node[p].next)//标记第一条链表
{
node[p].flag = 1;
}
for (p = ad2; p != -1; p = node[p].next)//寻找是否存在共用结点
{
if (node[p].flag == 1)
{
break;
}
}
if (p == -1)//输出
{
cout << "-1" << endl;
}
else
{
printf("%05d\n", p);
}
return 0;
}