HDU - 3999 E - The order of a Tree

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely: 
1.  insert a key k to a empty tree, then the tree become a tree with 
only one node; 
2.  insert a key k to a nonempty tree, if k is less than the root ,insert 
it to the left sub-tree;else insert k to the right sub-tree. 
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape. 

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n. 

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic. 

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4

题意:给一个序列,构建二叉搜索树,输出树的前序遍历。

分析:用数组模拟二叉树,用数组记录二叉树前序遍历。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int s[100010],left[100010],right[100010];
int sum[100010];
int len1,len2,num;
void tree(int l,int k)
{ 
    if(s[l]>=k)    //左子树
    {
        if(left[l])
            tree(left[l],k);
        else
            left[l]=len2;
    }
    else           //右子树
    {
        if(right[l])
            tree(right[l],k);
        else
            right[l]=len2;
    }
}
void check(int l)   //树的前序遍历
{
    sum[num++]=s[l];   
    if(left[l])     //查找左子树
        check(left[l]);
    if(right[l])    //右子树
        check(right[l]);
}
int main()
{
    int n,k;
    while(~scanf("%d",&n))
    {
        memset(left,0,sizeof(left));
        memset(right,0,sizeof(right));
        len1=-1;
        len2=0;
        num=0;
        for(int i=0; i<n; i++)  //建树
        {
            scanf("%d",&k);
            if(len1==-1)        //根节点
                s[++len1]=k;
            else
            {
                s[++len2]=k;
                tree(len1,k);
            }
        }
        check(len1);  //前序遍历
        for(int i=0; i<num; i++)
        {
            if(i==0)
                printf("%d",sum[i]);
            else
                printf(" %d",sum[i]);
        }
        printf("\n");
    }
}

 

回答: 引用\[1\]和引用\[2\]是关于解决HDU - 3853问题的AC代码。这段代码使用了动态规划的思路,通过计算每个点的期望能量来解决问题。其中,f\[i\]\[j\]表示走到(i, j)这个点的期望能量。代码中还有一些特殊情况的处理,比如停留在原地的花费为2点,停留在原地的概率为1的情况下期望能量为0。\[1\]\[2\] 引用\[3\]是关于Akemi Homura的描述,她是一个魔法少女,想要帮助她的朋友Madoka拯救世界。但由于Boss孵化器的情节,她被困在一个叫做LOOPS的迷宫中。\[3\] 所以,问题A - LOOPS HDU - 3853是关于解决迷宫问题的一个题目。 #### 引用[.reference_title] - *1* *3* [期望DP&mdash;&mdash;C - LOOPS HDU - 3853](https://blog.youkuaiyun.com/GreyBtfly/article/details/80534173)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* [HDU 3853-LOOPS【期望DP】](https://blog.youkuaiyun.com/qq_41785863/article/details/102570840)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值