1102 Invert a Binary Tree (25 分)

这篇博客主要介绍了如何实现二叉树的翻转并进行层次遍历和中序遍历。通过输入二叉树节点信息,程序将反转二叉树并输出翻转后的层次遍历和中序遍历序列。文章提供了两种不同的代码实现,一种采用传统的递归和队列,另一种使用了向量和排序。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

Analysis

题意大概如下:第一个数字N表示有N个节点。接下来N行表示第i行的左右子节点,如果是空就用 ‘-’ 表示。然后讲左右子节点反转,输出层级遍历的结果与中序遍历的结果。

这次的代码我选择最熟悉的写法,所以不太漂亮,但是成功AC,也让我收获了层级遍历的写法,文尾有柳神的代码。

Code(C++)

#include <iostream>
#include <vector>
#include <queue>
using namespace std;

typedef struct node *PtrToNode;
typedef PtrToNode Tree;

struct node {
    int id;
    PtrToNode Left;
    PtrToNode Right;
};

vector<int> in, level;
queue<PtrToNode> que;

void inorder(Tree T)
{
    if(T == NULL)
        return;
    
    inorder(T->Left);
    in.push_back(T->id);
    inorder(T->Right);
}

void levelorder(Tree T)
{
    if (T == NULL)
        return;
    
    PtrToNode ptr = T;
    que.push(ptr);
    while (!que.empty())
    {
        ptr = que.front();
        que.pop();
        level.push_back(ptr->id);
        if (ptr->Left != NULL)
            que.push(ptr->Left);
        if (ptr->Right != NULL)
            que.push(ptr->Right);
    }
}

int main()
{
    int n;
    cin >> n;
    
    bool flag[n];
    PtrToNode a[n];
    for(int i=0; i<n; i++)
    {
        a[i] = (PtrToNode)malloc(sizeof(struct node));
        a[i]->id = i;
        a[i]->Left = a[i]->Right = NULL;
        flag[i] = true;
    }
    
    
    for(int i=0; i<n; i++)
    {
        char l, r;
        cin >> l >> r;
        if(l != '-')
        {
            a[i]->Right = a[l-'0'];
            flag[l -'0'] = false;
        }
        if(r != '-')
        {
            a[i]->Left = a[r-'0'];
            flag[r-'0'] = false;
        }
    }
    
    Tree T;
    for(int i=0; i<n; i++)
        if(flag[i])
        {
            T = a[i];
            break;
        }
    
    levelorder(T);
    cout << level[0];
    for(int i=1; i<level.size(); i++)
        cout << " " << level[i];
    
    cout << endl;
    
    inorder(T);
    cout << in[0];
    for(int i=1; i<in.size(); i++)
        cout << " " << in[i];
}

柳神的代码,还是一如即往地选择vector来建树。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct node {
    int id, l, r, index, level;
} a[100];
vector<node> v1;
void dfs(int root, int index, int level) {
    if (a[root].r != -1) dfs(a[root].r, index * 2 + 2, level + 1);
    v1.push_back({root, 0, 0, index, level});
    if (a[root].l != -1) dfs(a[root].l, index * 2 + 1, level + 1);
}
bool cmp(node a, node b) {
    if (a.level != b.level) return a.level < b.level;
    return a.index > b.index;
}
int main() {
    int n, have[100] = {0}, root = 0;
    cin >> n;
    for (int i = 0; i < n; i++) {
        a[i].id = i;
        string l, r;
        cin >> l >> r;
        if (l != "-") {
            a[i].l = stoi(l);
            have[stoi(l)] = 1;
        } else {
            a[i].l = -1;
        }
        if (r != "-") {
            a[i].r = stoi(r);
            have[stoi(r)] = 1;
        } else {
            a[i].r = -1;
        }
    }
    while (have[root] == 1) root++;
    dfs(root, 0, 0);
    vector<node> v2(v1);
    sort(v2.begin(), v2.end(), cmp);
    for (int i = 0; i < v2.size(); i++) {
        if (i != 0) cout << " ";
        cout << v2[i].id;
    }
    cout << endl;
    for (int i = 0; i < v1.size(); i++) {
        if (i != 0) cout << " ";
        cout << v1[i].id;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值