Description
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5 1 2 20 2 3 30 3 4 20 4 5 20 1 5 100
Sample Output
90
这道题是一道求最短路的模板题,可以用Dijkstra或SPFA解决(也可以使用Bellman_Ford),下面是程序:
#include<queue>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
using namespace std;
struct edge{
int v,w;
edge *next;
}*head[1005];
bool vis[1005];
int dis[1005];
edge *make(){
return (edge *)(malloc(sizeof(edge)));
}
void add(int u,int v,int w){
edge *x=make();
x->v=v;
x->w=w;
x->next=head[u];
head[u]=x;
}
void SPFA(){
queue<int>q;
memset(dis,0x7f,sizeof(dis));
q.push(1);
dis[1]=0;
vis[1]=1;
while(!q.empty()){
int x=q.front();
vis[x]=0;
q.pop();
edge *now=head[x];
while(now){
if(dis[x]+now->w<dis[now->v]){
dis[now->v]=dis[x]+now->w;
if(!vis[now->v]){
q.push(now->v);
}
vis[now->v]=1;
}
now=now->next;
}
}
}
int main(){
int n,m,u,v,w;
scanf("%d%d",&m,&n);
while(m--){
scanf("%d%d%d",&u,&v,&w);
add(u,v,w);
add(v,u,w);
}
SPFA();
printf("%d\n",dis[n]);
return 0;
}