hdu1072 Nightmare(bfs)

本文介绍了一道关于迷宫逃脱的问题,通过BFS(宽度优先搜索)算法解决。问题中涉及特殊点位如起点、终点、障碍物及可重置时间的补给点等,需考虑时间限制和特殊点的功能。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9662    Accepted Submission(s): 4696


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
  
  
4 -1 13
 

题意:给你一个图,1代表路,0代表墙,2代表起始点,3代表终点,4可以重置炸弹时间,炸弹爆炸时间为6min,每走一步需要1min,如果时间变成0就算走到了3或者4也算死亡。问你能否走出,能输出步数,不能输出-1。

思路: 题目中有一句:如果你需要,可以重复到4这个点补充炸弹时间。其实并没有什么用,你经过了某一个4,根据广搜如果走不出的话无论你怎么回头再走这同一个4也是走不出去的,所以直接将如果经过一个4那么就把这个4设为0,就可以了。         还有一个最重要的问题,根据普通的广搜,我们有vis数组,走过的点都会标记成不能在走,但这个题如果经过了4点重置时间后,是很有可能需要走重复点的,为了解决这个就要在vis上作出改变了,我们只需要用vis记录每次经过一点时候boom所剩余的时间,如果两次经过某一点剩余时间不同,说明时间得到了补充,那么就可以重复走。



Code:
/*******************************************
FileName:bfs
Author:苏相学
Date:2016年6月26日15:44:37
Description:功能
Others:
********************************************/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;

const int maxn = 105;

struct node{
    int x,y,time;
}nex,now;

int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
int map[120][120];
int vis[120][120];
int output[120][120];
int m,n;

void bfs(int x,int y)
{
    queue<node> s;
    memset(vis,0,sizeof(vis));
    memset(output,0,sizeof(output));
    vis[x][y]=6;
    now.x=x;
    now.y=y;
    now.time=6;
    s.push(now);
    while(!s.empty())
    {
        now=s.front();
        s.pop();
        for(int i=0;i<4;i++){
            nex.x=now.x+fx[i];
            nex.y=now.y+fy[i];
            nex.time=now.time;
            if(nex.x>=0&&nex.x<n&&nex.y>=0&&nex.y<m&&vis[nex.x][nex.y]!=nex.time&&map[nex.x][nex.y]!=0)
            {
                    if(map[nex.x][nex.y]==4)
                    {
                        nex.time=now.time-1;
                        if(nex.time==0) continue;
                        output[nex.x][nex.y]=output[now.x][now.y]+1;
                        vis[nex.x][nex.y]=nex.time;
                        nex.time=6;
                        s.push(nex);
                        map[nex.x][nex.y]=0;
                    }
                    if(map[nex.x][nex.y]==1)
                    {
                        output[nex.x][nex.y]=output[now.x][now.y]+1;
                        nex.time=now.time-1;
                        vis[nex.x][nex.y]=nex.time;
                        if(nex.time==0) continue;
                        s.push(nex);
                    }
                    if(map[nex.x][nex.y]==3)
                    {
                        nex.time=now.time-1;
                        if(nex.time==0) continue;
                        printf("%d\n",output[now.x][now.y]+1);
                        return ;
                    }
            }
        }

    }
    printf("-1\n");
    return ;
}

int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        int x,y;
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j]==2)
                {
                    x=i;
                    y=j;
                }
            }
         bfs(x,y);
    }
    return 0;
}



这个题算是需要一点技巧的bfs了,参考了大牛的博客才慢慢理解,也算是练习了一下吧。




内容概要:《2024年中国城市低空经济发展指数报告》由36氪研究院发布,指出低空经济作为新质生产力的代表,已成为中国经济新的增长点。报告从发展环境、资金投入、创新能力、基础支撑和发展成效五个维度构建了综合指数评价体系,评估了全国重点城市的低空经济发展状况。北京和深圳在总指数中名列前茅,分别以91.26和84.53的得分领先,展现出强大的资金投入、创新能力和基础支撑。低空经济主要涉及无人机、eVTOL(电动垂直起降飞行器)和直升机等产品,广泛应用于农业、物流、交通、应急救援等领域。政策支持、市场需求和技术进步共同推动了低空经济的快速发展,预计到2026年市场规模将突破万亿元。 适用人群:对低空经济发展感兴趣的政策制定者、投资者、企业和研究人员。 使用场景及目标:①了解低空经济的定义、分类和发展驱动力;②掌握低空经济的主要应用场景和市场规模预测;③评估各城市在低空经济发展中的表现和潜力;④为政策制定、投资决策和企业发展提供参考依据。 其他说明:报告强调了政策监管、产业生态建设和区域融合错位的重要性,提出了加强法律法规建设、人才储备和基础设施建设等建议。低空经济正加速向网络化、智能化、规模化和集聚化方向发展,各地应找准自身比较优势,实现差异化发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值