HDU 5875 - Function

Problem Description
The shorter, the simpler. With this problem, you should be convinced of this truth.
 
  You are given an array A of N postive integers, and M queries in the form (l,r). A function F(l,r) (1≤l≤r≤N) is defined as:
F(l,r)={AlF(l,r−1) modArl=r;l<r.
You job is to calculate F(l,r), for each query (l,r).


Input
There are multiple test cases.
 
  The first line of input contains a integer T, indicating number of test cases, and T test cases follow.
 
  For each test case, the first line contains an integer N(1≤N≤100000).
  The second line contains N space-separated positive integers: A1,…,AN (0≤Ai≤109).
  The third line contains an integer M denoting the number of queries.
  The following M lines each contain two integers l,r (1≤l≤r≤N), representing a query.


Output
For each query(l,r), output F(l,r) on one line.


Sample Input
1
3
2 3 3
1
1 3


Sample Output
2
 
题意:给出 n 个数,然后给出一个区间,求出这个区间中的第一个数不断向后取模预算到最后的结果。

因为和比自己大的数取模的结果还是他自己,所以只需要和自己小的数取模即可。做一个数组专门用来储存这个数后面第一个比他小的,这样每次找后一个并且取模。

#include <cstdio>

int num[100000 + 5];
int next[100000 + 5];

int main()
{
    int T;
    scanf("%d", &T);

    while (T--)
    {
        int n;
        scanf("%d", &n);
        for (int i = 0; i < n; ++i)
            scanf("%d", &num[i]);

        for (int i = 0; i < n; ++i)
        {
            next[i] = -1;
            for (int j = i + 1; j < n; ++j)
            {
                if (num[j] <= num[i])
                {
                    next[i] = j;
                    break;
                }
            }
        }

        int t;
        scanf("%d", &t);
        while (t--)
        {
            int left, right;
            scanf("%d%d", &left, &right);
            left--;

            int ans = num[left];
            for (int i = next[left]; i < right; i = next[i])
            {
                if (i == -1)
                    break;
                ans %= num[i];
            }
            printf("%d\n", ans);
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值