Description
The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.
Input
Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.
Output
For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.
Sample Input
3 0 1 10 10 1 0 1 2 10 1 0 10 10 2 10 0 0
Sample Output
8
又是一道状态压缩的DP题,题目思路和POJ1185类似:可戳
只是需要先把各个点之间用Floyd找一遍最短路。
#include <cstdio>
#include <cstring>
const int INF = (1<<30)-1;
int dis[15][15];
int ans[1<<11][15];
inline int minn(int a, int b) {
return a < b ? a : b;
}
int main()
{
int n;
while (scanf("%d", &n)!=EOF)
{
if (n == 0) break;
for (int i = 0; i <= n; ++i)
for (int j = 0; j <= n; ++j)
scanf("%d", &dis[i][j]);
for (int i = 0; i <= n; ++i)//Floyd
for (int j = 0; j <= n; ++j)
for (int k = 0; k <= n; ++k)
dis[j][k] = minn(dis[j][k], dis[j][i] + dis[i][k]);
ans[1][0] = 0;
for (int S = 0; S <= (1<<n)-1; ++S)//使用位运算枚举所有状态
{
for (int i = 1; i <= n; ++i)
{
if (S & (1<<(i-1)))
{
if (S == (1<<(i-1)))//只经过了i这个城市
ans[S][i] = dis[0][i];
else//还有别的城市
{
ans[S][i] = INF;
for (int j = 1; j <= n; ++j)
{
if (S & (1<<(j-1)) && j != i)//不是i的其他城市
ans[S][i] = minn(ans[S][i], ans[S^(1<<(i-1))][j] + dis[j][i]);
}
}
}
}
}
int ret = ans[(1<<n)-1][1] + dis[1][0];
for (int i = 2; i <= n; ++i)
ret = minn(ret, ans[(1<<n)-1][i] + dis[i][0]);
printf("%d\n", ret);
}
return 0;
}