【DP】Hurdles of 110m

本文介绍了2008年北京奥运会前刘翔在110米跨栏比赛中的挑战。在2004年雅典奥运会上,刘翔以近乎完美的技术赢得金牌,并承诺在2008年北京奥运会上卫冕。比赛中,运动员需在每个部分选择快、正常或慢三种模式,每种模式有不同的时间和力量消耗。问题要求通过动态规划找到刘翔以最短时间内完成比赛的策略。样例输入和输出展示了如何计算最短时间。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

描述

In the year 2008, the 29th Olympic Games will be held in Beijing. This will signify the prosperity of China and Beijing Olympics is to be a festival for people all over the world as well.

Liu Xiang is one of the famous Olympic athletes in China. In 2002 Liu broke Renaldo Nehemiah’s 24-year-old world junior record for the 110m hurdles. At the 2004 Athens Olympics Games, he won the gold medal in the end. Although he was not considered as a favorite for the gold, in the final, Liu’s technique was nearly perfect as he barely touched the sixth hurdle and cleared all of the others cleanly. He powered to a victory of almost three meters. In doing so, he tied the 11-year-old world record of 12.91 seconds. Liu was the first Chinese man to win an Olympic gold medal in track and field. Only 21 years old at the time of his victory, Liu vowed to defend his title when the Olympics come to Beijing in 2008.

In the 110m hurdle competition, the track was divided into N parts by the hurdle. In each part, the player has to run in the same speed; otherwise he may hit the hurdle. In fact, there are 3 modes to choose in each part for an athlete – Fast Mode, Normal Mode and Slow Mode. Fast Mode costs the player T1 time to pass the part. However, he cannot always use this mode in all parts, because he needs to consume F1 force at the same time. If he doesn’t have enough force, he cannot run in the part at the Fast Mode. Normal Mode costs the player T2 time for the part. And at this mode, the player’s force will remain unchanged. Slow Mode costs the player T3 time to pass the part. Meanwhile, the player will earn F2 force as compensation. The maximal force of a player is M. If he already has M force, he cannot earn any more force. At the beginning of the competition, the player has the maximal force.

The input of this problem is detail data for Liu Xiang. Your task is to help him to choose proper mode in each part to finish the competition in the shortest time.

输入

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

Each test case begins with two positive integers N and M. And following N lines denote the data for the N parts. Each line has five positive integers T1 T2 T3 F1 F2. All the integers in this problem are less than or equal to 110.

输出

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the shortest time that Liu Xiang can finish the competition.

样例输入

2
1 10
1 2 3 10 10
4 10
1 2 3 10 10
1 10 10 10 10
1 1 2 10 10
1 10 10 10 10

样例输出

1
6

分析:
有三种跨栏方式,要求最短时间得完成所有跨栏(动态规划)。
反思:
查了半天DP循环发现没问题,发现是初始化写错了。
代码:

#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
int main()
{
    int T,T1[200],T2[200],T3[200],F1[200],F2[200];
    int dp[200][200];
    cin>>T;
    while(T--)
    {
        int mini=INF;
        int n,m;
        memset(dp,INF,sizeof(dp));
        //cout<<dp[0][0];
        cin>>n>>m;
        for (int i=1;i<=n;i++)
            cin>>T1[i]>>T2[i]>>T3[i]>>F1[i]>>F2[i];
        for (int i=0;i<=m;i++)
        {
            dp[0][i]=0;
        }
        for (int i=1;i<=n;i++)
        {
            for (int j=0;j<=m;j++)
            {
                dp[i][j]=min(dp[i][j],dp[i-1][j]+T2[i]);
                //case 1
                if (j-F1[i]>=0)
                   dp[i][j-F1[i]]=min(dp[i][j-F1[i]],dp[i-1][j]+T1[i]);
                //case 2
                if (j+F2[i]<=m)
                {
                    dp[i][j+F2[i]]=min(dp[i][j+F2[i]],dp[i-1][j]+T3[i]);
                }
                else
                {
                    dp[i][m]=min(dp[i][m],dp[i-1][j]+T3[i]);
                }
                //case 3
            }
        }
        /*for (int i=1;i<=n;i++)
        {
            for (int j=1;j<=m;j++)
            cout<<dp[n][i]<<' ';
            cout<<endl;
        }*/
        for (int i=0;i<=m;i++)
        {
            mini=min(mini,dp[n][i]);
        }
        cout<<mini<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值