(poj2559) Largest Rectangle in a Histogram

本文探讨了如何在一组宽度相同但高度各异的矩形中寻找最大面积的矩形,利用单调栈解决这一经典问题。通过左右边界计算每个矩形可能的最大面积,最终找出全局最优解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Largest Rectangle in a Histogram

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
这是图片
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

Source

Ulm Local 2003

题目大意

   给你几个高度不同,宽度为1的长方形,拼成一张图,求最大矩形面积

题解:

   本题是单调栈(当然你也可以去模拟单调栈或用单调队列来做)

PS:

   关于栈函数的用法介绍,可以看这里(虽然这里说的是队列函数,但是是一样的)

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <stack>

using namespace std;
int n;
int a[100010],l[100010],r[100010];
stack <int> s;
long long ans;
int main()
{

    while(scanf("%d",&n)&&n)//多组数据
    {
        ans=0;
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        while(!s.empty()) s.pop();
        for(int i=1;i<=n;i++)
        {
            while(!s.empty()&&a[s.top()]>=a[i]) s.pop();
            if(s.empty()) l[i]=0;
                     else l[i]=s.top();
            s.push(i);
        }
        while(!s.empty()) s.pop();
        for(int i=n;i>=1;i--)
        {
            while(!s.empty()&&a[s.top()]>=a[i]) s.pop();
            if(s.empty()) r[i]=n+1;
                     else r[i]=s.top();
            s.push(i);
        }
        for(int i=1;i<=n;i++)
            ans=max(ans,(long long)((long long)r[i]-(long long)l[i]-1LL)*(long long)a[i]);
        printf("%lld\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值