题目链接:http://codeup.cn/problem.php?cid=100000605&pid=0
题目描述
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
输入
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
输出
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
样例输入
30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0
样例输出
12178.21
代码
#include <iostream>
#include <cstdio>
#include <string>
#include <stack>
#include <queue>
#include <map>
using namespace std;
struct node {
double num;
char op;
bool flag;
};
string str;
stack<node> s;
queue<node> q;
map<char, int> op;
void Change() { //转化成后缀表达式
node temp;
for(int i = 0; i < str.length();) {
if(str[i] >= '0' && str[i] <= '9') { //若未操作数
temp.flag = true;
temp.num = str[i++] - '0';
while(i < str.length() && str[i] >= '0' && str[i] <= '9') {
temp.num = temp.num * 10 + (str[i] - '0');
i++;
}
q.push(temp);
}
else { //若为操作符
temp.flag= false;
while(!s.empty() && op[str[i]] <= op[s.top().op]) {
q.push(s.top());
s.pop();
}
temp.op = str[i];
s.push(temp);
i++;
}
}
while(!s.empty()) { //将栈中剩余操作符存入队列
q.push(s.top());
s.pop();
}
}
double Cal() { //计算中缀表达式的值
double temp1, temp2;
node cur, temp;
while(!q.empty()) {
cur = q.front();
q.pop();
if(cur.flag == true) //若为操作数,压入栈
s.push(cur);
else { //若为操作符,弹出栈中两个操作数,计算
temp2 = s.top().num; //注意:先弹出的为第二操作数
s.pop();
temp1 = s.top().num;
s.pop();
temp.flag = true;
if(cur.op == '+')
temp.num = temp1 + temp2;
else if(cur.op == '-')
temp.num = temp1 - temp2;
else if(cur.op == '*')
temp.num = temp1 * temp2;
else
temp.num = temp1 / temp2;
s.push(temp);
}
}
return s.top().num;
}
int main() {
op['+'] = op['-'] = 1;
op['*'] = op['/'] = 2;
while(getline(cin, str), str != "0") {
string::iterator it;
for(it = str.begin(); it != str.end(); it++) {
if(*it == ' ')
str.erase(it);
}
while(!s.empty())
s.pop();
Change();
printf("%.2f\n", Cal());
}
return 0;
}
算法思想:
- 先将中缀表达式转化成后缀表达式(存入队列):
依次扫描表达式,若是操作数就存入队列;
若是操作符就和栈顶的操作符优先级比较,若大于栈顶优先级,则直接压入栈;
若小于等于栈顶优先级,则把栈顶弹出到队列中,再比较,直到优先级大于栈顶,压入栈;
最后若栈内还有操作符,就依次弹出,存入队列。 - 再通过后缀表达式计算值
依次扫描队列,若是操作数则存入栈中;
若是操作符则弹出栈顶和次栈顶元素,计算后再压入栈内;
直到扫描结束,则栈顶的元素即使要求的值;