Accept: 47 Submit: 191
Time Limit: 1000 mSec Memory Limit : 262144 KB
Problem Description
N wizards are attending a meeting. Everyone has his own magic wand. N magic wands was put in a line, numbered from 1 to n(Wand_i owned by wizard_i). After the meeting, n wizards will take a wand one by one in the order of 1 to n. A boring wizard decided to reorder the wands. He is wondering how many ways to reorder the wands so that at least k wizards can get his own wand.
For example, n=3. Initially, the wands are w1 w2 w3. After reordering, the wands become w2 w1 w3. So, wizard 1 will take w2, wizard 2 will take w1, wizard 3 will take w3, only wizard 3 get his own wand.
Input
First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.
For each test case: Two number n and k.
1<=n <=10000.1<=k<=100. k<=n.
Output
For each test case, output the answer mod 1000000007(10^9 + 7).
Sample Input
Sample Output
Source
第八届福建省大学生程序设计竞赛-重现赛(感谢承办方厦门理工学院)
思路:全部的排列减去不符合情况的排列数量(不符合的情况是:0~k-1个东西不在自己的位置上)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b) memset(a,b,sizeof(a))
#define maxn 510
const int M=1e6+10;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
int i,j,k,n,m;
int r1,r2,l1,l2;
ll d[M];
ll c[M];
ll a[M];
void init()
{
d[0]=0;d[1]=0;d[2]=1;
for(int i=3;i<=10000;i++){
d[i]=(((i-1)%mod)*((d[i-1]+d[i-2])%mod))%mod;
}
a[0]=1;
for(int i=1;i<=10000;i++){
a[i]=(a[i-1]*i)%mod;
}
}
ll ex_gcd(ll a,ll b,ll &x,ll &y)
{
ll d=a;
if(b!=0){
d=ex_gcd(b,a%b,y,x);
y-=(a/b)*x;
}
else {
x=1;
y=0;
}
return d;
}
ll mod_inverse(int b,int mod)
{
ll x,y;
ex_gcd(b,mod,x,y);
return (mod+x%mod)%mod;
}
void solve(int n,int k)
{
c[0]=1;
for(int i=1;i<=k;i++){
ll kk=mod_inverse(i,mod);
c[i]=(c[i-1]*kk)%mod;
c[i]=(c[i]*(n-i+1))%mod;
}
}
int main()
{
int t;
scanf("%d",&t);
init();
while(t--){
scanf("%d%d",&n,&k);
solve(n,k);
ll ans=0;
for(int i=0;i<=k-1;i++){
ans+=((d[n-i])*c[i])%mod;
ans%=mod;
}
ans=(a[n]-ans+mod)%mod;
printf("%lld\n",ans);
}
return 0;
}