POJ 1734.Sightseeing trip

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, …, y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,…,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+…+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string ‘No solution.’ in case there isn’t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input
5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20
Sample Output
1 3 5 2

大意:寻找最少经过三个结点的环,环上结点不重复,并且道路长度最小,称为无向图的最小环问题,本题是SPJ,任意一种均可

Floyd

在Floyd算法中,D[i][j]表示经过编号不超过k-1的结点,从ij的最短路,所以只要枚举一个结点k,求i->k->j成环的最小长度即可

要求输出路径,用pos[i][j]表示ij经过的点,递归寻找出路径

#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;

const int maxn = 105;
int d[maxn][maxn], a[maxn][maxn], pos[maxn][maxn];
int n, m, ans = 0x3f3f3f3f;
vector<int> path;

void getPath(int x, int y)
{
    if (pos[x][y] == 0) return;
    getPath(x, pos[x][y]);
    path.push_back(pos[x][y]);
    getPath(pos[x][y], y);
}
int main()
{
    scanf("%d %d", &n, &m);
    memset(a, 0x3f, sizeof(a));
    for (int i = 1; i <= n; ++i) a[i][i] = 0;
    for (int i = 1; i <= m; ++i)
    {
        int x, y, z;
        scanf("%d %d %d", &x, &y, &z);
        a[x][y] = a[y][x] = min(a[x][y], z);
    }
    memcpy(d, a, sizeof(a));
    for (int k = 1; k <= n; ++k)
    {
        for (int i = 1; i < k; ++i)//不经过k
            for (int j = i + 1; j < k; ++j)//不重
            {
                if ((long long)d[i][j] + a[j][k] + a[k][i] < ans)//成环,结果最小
                {
                    ans = d[i][j] + a[j][k] + a[k][i];
                    path.clear();
                    path.push_back(i);
                    getPath(i, j);
                    path.push_back(j);
                    path.push_back(k);
                }
            }
        for (int i = 1; i <= n; ++i)
            for (int j = 1; j <= n; ++j)
                if (d[i][j] > d[i][k] + d[k][j])//更新最短路
                {
                    d[i][j] = d[i][k] + d[k][j];
                    pos[i][j] = k;
                }
    }
    if (ans == 0x3f3f3f3f)
        printf("No solution.\n");
    else 
        for (int i = 0; i < path.size(); ++i)
            printf("%d%c", path[i], " \n"[i == path.size() - 1]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值