POJ 3263.Tallest Cow
Description
FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line.
Each cow has a positive integer height (which is a bit of secret).
You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.
FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34".
This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.
For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct.
It is guaranteed that it is possible to satisfy all the constraints.
Input
Line 1: Four space-separated integers: N, I, H and R
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.
Output
Lines 1..N: Line i contains the maximum possible height of cow i.
Sample Input
9 3 5 5
1 3
5 3
4 3
3 7
9 8
Sample Output
5
4
5
3
4
4
5
5
5
开始身高全为0,如果A可以看到B那么就把A到B之间所有牛的身高减一,代表比他们两个矮,然后把区间操作改变为对端点操作,通过前缀和得到答案
关系可能会多次输入,要判重
#include <map>
#include <iostream>
using namespace std;
static const auto io_sync_off = []() {
std::ios::sync_with_stdio(false);
std::cin.tie(nullptr);
return nullptr;
}();
using paii = pair<int, int>;
map<paii, bool> m;
const int maxn = 10005;
int arr[maxn], high[maxn];
int main()
{
int n, p, h, k;
cin >> n >> p >> h >> k;
int a, b;
for (int i = 0; i < k; ++i)
{
cin >> a >> b;
if (a > b)
swap(a, b);
if (m[make_pair(a, b)])
continue;
arr[a + 1] -= 1;//a+1开始身高矮1
arr[b] += 1;//到b结束
m[make_pair(a, b)] = true;
}
for (int i = 1; i <= n; ++i)
{
high[i] = high[i - 1] + arr[i];//前缀和,代表比0身高高或矮多少
cout << high[i] + h << endl;
}
return 0;
}