POJ 3259_Bellman Ford_判断是否含负权环

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44853 Accepted: 16530
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output

Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output

NO
YES
Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

#include<iostream>
using namespace std;
#include<vector>
int F,N,M,W;
const int INF=1<<30;
struct Edge
{
    int s,e,w;
    Edge(int ss,int ee,int ww):s(ss),e(ee),w(ww) {}
    Edge() {}
};
vector<Edge> edges; //all edges
int dist[1010];
int Bellman_ford(int v)
{
    for (int i=1;i<=N;i++)
        dist[i]=INF;
    dist[v]=0;
    for (int k=1;k<N;k++)
    {
        for (int i=0;i<edges.size();i++)
        {
            int s=edges[i].s;
            int e=edges[i].e;
            if (dist[s]+edges[i].w<dist[e])
                dist[e]=dist[s]+edges[i].w;
        }
    }
    //加上是否有负权边的判断
    for (int i=0;i<edges.size();i++)
    {
        int s=edges[i].s;
        int e=edges[i].e;
        if (dist[s]+edges[i].w<dist[e])
            return true; //即判断:dist[u]+w(u,k)<dist[k]  是否成立,如果成立,则说明存在从源点可达的负权值回路
    }
    return false;
}
int main()
{
    cin>>F;
    while (F--)
    {
        edges.clear();
        cin>>N>>M>>W;
        for (int i=0;i<M;i++)
        {
            int s,e,t;
            cin>>s>>e>>t;
            edges.push_back(Edge(s,e,t));
            edges.push_back(Edge(e,s,t));
        }
        for (int i=0;i<W;i++)
        {
            int s,e,t;
            cin>>s>>e>>t;
            edges.push_back(Edge(s,e,-t));
        }
        if (Bellman_ford(1))
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

注:(摘自北大2016ACM/ICPC暑期课讲义)

 for (int k=1;k<N;k++)
    {
        for (int i=0;i<edges.size();i++)
        {
            int s=edges[i].s;
            int e=edges[i].e;
            if (dist[s]+edges[i].w<dist[e])
                dist[e]=dist[s]+edges[i].w;
        }
    }

在一次内层循环中,更新了某个 dist[x]后,以后又用dist[x]去更新 dist[y],这样dist[y]就是经过最多不超过k+1条边的情况了

出现这种情况没有关系,因为整个 for( int k = 1; k < N; ++k) 循环的目的是 要确保,对任意点u,如果从源s到u的最短路是经过不超过n-1条边的,则这条最短路不会 被忽略。至于计算过程中对某些点 v 计算出了从s->v的经过超过N-1条边的最短路的 情况,也不影响结果正确性。若是从s->v的经过超过N-1条边的结果比经过最多N-1条 边的结果更小,那一定就有负权回路。有负权回路的情况下,再多做任意多次循环, 每次都会发现到有些点的最短路变得更短了。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值