pat甲级1002.A+B for Polynomials

题目信息:
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

翻译:
这一次你要计算两个多项式A和B的和.

输入:
每次输入包含一个测试样例.每个样例两行,每一行包含多项式的以下信息: K N1 aN1 N2 aN2 … NK aNK, K是多项式中非零项的个数,Ni 和aNi (i=1, 2, …, K) 是非零项的指数和系数,并且1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

输出:
对每一个测试样例,你应该在一行中输出多项式A和B的和,并且以与输入相同的格式的输出.注意行末没有多余空格,精确到一位小数.

样例输入:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

样例输出:
3 2 1.5 1 2.9 0 3.2

思路分析:
使用栈这种ADT来处理这一题.

  1. 对于两个多项式,分别新建栈L1,L2来存储它们.由于输入中指数是降序的,为以后的合并提供了很大的方便.
    这里写图片描述

  2. 合并时首先判断两个栈是否均为非空,均为非空时,比较栈中第一个节点指数的大小,指数小的节点压入合并后的栈L中,并对这个节点所在的栈执行Pop操作,再次执行步骤2. 而当两个节点的指数相等时,判断两个节点的系数和是否为0:若为0,则直接对这两个栈执行Pop操作,再次执行步骤2直到不满足条件为止;若不为0,则将其系数相加后和指数压入L中,对这两个栈执行Pop操作,再次执行步骤2直到不满足条件为止.

  3. 依次判断L1,L2是否为空,若不为空,则将其节点压入L中,并执行Pop操作直到其变为空栈.至此合并完成.

  4. 打印栈L.(其中L的节点个数可以用L头结点中的指数来表示,在初始化时这个值置零,然后每一次对L执行Push操作时,这个值加1)

注意:当合并后的链表为空,即所有的系数均为零时,输出”0”即可.

代码(我的环境为vs2017):

#include "stdafx.h"
#include <iostream>
#include <stdio.h>
#include <iomanip>
#include <stdlib.h>
#include <math.h>
#include <string.h>
using namespace std;

struct Node
{
    int Exp;
    double Coe;
    Node* Next;
};
typedef Node* List;
class Stack
{
public:
    List CreateList()
    {
        List L = new Node;
        L->Coe = L->Exp = 0;
        L->Next = NULL;
        return L;
    }
    bool IsEmpty(List L)
    {
        return L->Next == NULL;
    }
    List Push(int Exp, double Coe,List L)
    {
        List NewCell = new Node;
        NewCell->Coe = Coe;
        NewCell->Exp = Exp;
        NewCell->Next = NULL;
        NewCell->Next = L->Next;
        L->Next = NewCell;
        return L;
    }
    List Pop(List L)
    {
        if (IsEmpty(L))
            return NULL;
        List Tmp = L->Next;
        L->Next = L->Next->Next;
        delete Tmp;
    }
    List Merge(List L1, List L2)
    {
        List L = CreateList();
        List P1 = L1->Next, P2 = L2->Next;
        while (1)
        {
            P1 = L1->Next, P2 = L2->Next;
            if (!(P1 != NULL&&P2 != NULL))
                break;
            if (P1->Exp < P2->Exp)
            {
                Push(P1->Exp, P1->Coe, L);
                Pop(L1);
                L->Exp++;
            }
            else if (P1->Exp > P2->Exp)
            {
                Push(P2->Exp, P2->Coe, L);
                Pop(L2);
                L->Exp++;
            }
            else
            {
                if (abs(P1->Coe + P2->Coe) > 0.0001)
                {
                    Push(P1->Exp, P1->Coe + P2->Coe, L);
                    L->Exp++;
                }
                Pop(L1);
                Pop(L2);
            }
        }
        while (1)
        {
            P1 = L1->Next;
            if (P1 == NULL)
                break;
            Push(P1->Exp, P1->Coe, L);
            Pop(L1);
            L->Exp++;
        }
        while (1)
        {
            P2 = L2->Next;
            if (P2 == NULL)
                break;
            Push(P2->Exp, P2->Coe, L);
            Pop(L2);
            L->Exp++;
        }
        return L;
    }
    void Print(List L)
    {
        if (L->Next == NULL)
        {
            cout << "0\n";
            return;
        }
        cout << L->Exp << " ";
        List P;
        for (int i = 0; i < L->Exp - 1; i++)
        {
            P = L->Next;
            cout << P->Exp << " " <<fixed<<setprecision(1)<< P->Coe << " ";
            Pop(L);
        }
        cout << L->Next->Exp << " " << fixed << setprecision(1) << L->Next->Coe << endl;
    }
};
int main()
{
    Stack S;
    List L1 = S.CreateList();
    List L2 = S.CreateList();
    int K1, K2;
    scanf("%d", &K1);
    int Exp;
    double Coe;
    for (int i = 0; i < K1; i++)
    {
        scanf("%d", &Exp);
        scanf("%lf", &Coe);
        S.Push(Exp, Coe, L1);
    }
    scanf("%d", &K2);
    for (int i = 0; i < K2; i++)
    {
        scanf("%d", &Exp);
        scanf("%lf", &Coe);
        S.Push(Exp, Coe, L2);
    }
    List L= S.Merge(L1, L2);
    S.Print(L);
    return 0;
}
1002 A+B for Polynomials 是一道编程题目,通常是在考察Java中处理多项式加法的问题。在这个问题中,你需要编写一个程序,让用户输入两个多项式的系数(如a_n*x^n + a_{n-1}*x^{n-1} + ... + a_1*x + a_0的形式),然后计算它们的和,并按照同样的形式表示出来。 在Java中,你可以创建一个`Polynomial`类,包含一个数组来存储系数和最高次数的信息。用户输入的每个多项式可以被解析成这样的结构,然后通过遍历并累加系数来完成加法操作。最后,将结果转换回字符串形式展示给用户。 以下是简化版的代码示例: ```java class Polynomial { int[] coefficients; int degree; // 构造函数,初始化数组 public Polynomial(int[] coeffs) { coefficients = coeffs; degree = coefficients.length - 1; } // 加法方法 Polynomial add(Polynomial other) { Polynomial result = new Polynomial(new int[coefficients.length + other.coefficients.length]); for (int i = 0; i < coefficients.length; ++i) { result.coefficients[i] += coefficients[i]; } for (int i = 0; i < other.coefficients.length; ++i) { result.coefficients[i + coefficients.length] += other.coefficients[i]; } result.degree = Math.max(degree, other.degree); return result; } @Override public String toString() { StringBuilder sb = new StringBuilder(); if (degree >= 0) { for (int i = degree; i >= 0; --i) { sb.append(coefficients[i]).append('*x^').append(i).append(" + "); } // 移除最后一个 " + " sb.setLength(sb.length() - 2); } else { sb.append("0"); } return sb.toString(); } } // 主函数示例 public static void main(String[] args) { Polynomial poly1 = new Polynomial(...); // 用户输入第一个多项式的系数 Polynomial poly2 = new Polynomial(...); // 用户输入第二个多项式的系数 Polynomial sum = poly1.add(poly2); System.out.println("Result: " + sum); } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值