POJ - 2456 Aggressive cows

Subsequence
Time limit 1000 ms Memory limit 65536 kB

Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C
* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output
* Line 1: One integer: the largest minimum distance

Sample Input
5 3
1
2
8
4
9

Sample Output
3

题目大意:给你n个点代表牛圈的位置,然后m只牛,让你尽量将牛分开使他们的距离最远。

解法:二分呀(●´ω`●)φ

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m;
int a[100005];
bool search(int d)
{
    int last=0;
    for(int i=1;i<m;i++)
    {
        int front=last+1;
        while(front<n&&a[front]-a[last]<d)
            front++;
        if(front==n)
            return false;
        last=front;
    }
    return true;
}

void solve()
{
    for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
    //cout<<a[0];
    sort(a,a+n);
    int l=0;
    int r=1e5+5;
    while(r-l>1)
    {
        int mid=(l+r)/2;
        if(search(mid))
            l=mid;
        else
            r=mid;
    }
    printf("%d\n",l);
}
int main()
{
    scanf("%d%d",&n,&m);
    solve();
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值