HDU_1260 Tickets

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
  
  
2 2 20 25 40 1 8
 

Sample Output
  
  
08:00:40 am 08:00:08 am
 

Source

题意:n个人排成一队去买票,每个单独买时用时t[i], 每个人可以和前后两个人中的一个人组成一队一起买用时sum_t[i](考虑前后组队,代表第i个人和第i-1个人一起买票),求所有人买完票总用时的最小值。

思路: dp[i][0]代表第i个数直接加上去所得最小值,dp[i][1]代表第i个数和第i-1个数共同加上去所得的最小值,每个人不能既和前一个又和后一个人组队一起买。
故有状态转移:

    dp[i][0] = min(dp[i-1][0] + t[i], dp[i-1][1] + t[i])
    dp[i][1] = dp[i-1][0] - t[i-1] + sum_t[i]

#include <bits/stdc++.h>

using namespace std;
const int inf = 1e9;
const int MAXN = 2000 + 7;
//dp[i][0]代表第i个数直接加上去所得最小值,dp[i][1]代表第i个数和第i-1个数共同加上去所得的最小值
int dp[MAXN][2], t[MAXN], sum_t[MAXN];

int main()
{
        int cas, n;
        scanf("%d", &cas);
        while(cas--) {
                scanf("%d", &n);
                int pos = 0;
                for(int i = 0; i < n; ++i) {
                     scanf("%d", &t[i]);
                }
                for(int i = 1; i < n; ++i) {
                        scanf("%d", &sum_t[i]);
                }
                dp[0][0] = t[0];
                dp[0][1] = inf;
                for(int i = 1; i < n; ++i) {
                        dp[i][0] = min(dp[i-1][0] + t[i], dp[i-1][1] + t[i]);
                        dp[i][1] = dp[i-1][0] + sum_t[i] - t[i-1];
                }
                int h, m, s;
                int ans = min(dp[n-1][0] , dp[n-1][1]);
                h = ans / 3600;
                m = (ans - h*3600) / 60;
                s = ans - 3600*h - m*60;
                h += 8;
                h < 12 ? printf("%02d:%02d:%02d am\n", h, m, s) : printf("%02d:%02d:%02d pm\n", h, m, s);
        }
        return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值