Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30
贪心思路:
1.使用数组标记搬运桌子的路径的开始到结尾经过路径
2.从走廊的最开始位置出发,循环比较得出当前路径标记的最大值
3.循环结束后综合了每次循环得到的局部最优值得到搬运路径的最大的重叠,则为问题的解
我的想法:
只需求出每个编号的最大重叠数量即可
然而没有考虑房间号顺序以及没看清题目房间是对门的,WA了好几遍qwq
1.使用数组标记搬运桌子的路径的开始到结尾经过路径
2.从走廊的最开始位置出发,循环比较得出当前路径标记的最大值
3.循环结束后综合了每次循环得到的局部最优值得到搬运路径的最大的重叠,则为问题的解
我的想法:
只需求出每个编号的最大重叠数量即可
然而没有考虑房间号顺序以及没看清题目房间是对门的,WA了好几遍qwq
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
int t,i,n,j,max;
int a[205][2],b1,b2;
int s[410];
scanf("%d",&t);
while(t--){
max=0;
memset(s,0,sizeof(s));
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d%d",&b1,&b2);
a[i][0]=(b1+1)/2;
a[i][1]=(b2+1)/2;
if(a[i][0]>a[i][1]){
a[i][0]^=a[i][1];
a[i][1]^=a[i][0];
a[i][0]^=a[i][1];
}
}
for(i=0;i<n;i++){
for(j=0;j<n;j++){
if(a[i][0]<=a[j][1]&&a[i][0]>=a[j][0])
s[i]++;
}
}
for(i=0;i<n;i++){
for(j=0;j<n;j++){
if(a[i][1]<=a[j][1]&&a[i][1]>=a[j][0])
s[i+n]++;
}
}
for(i=0;i<2*n;i++){
max=max<s[i]? s[i]:max;
}
printf("%d\n",10*max);
}
return 0;
}