The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
- 二分
- 把左右分开算
- 记得先排序 - -
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main(){
vector<int>ab;
int a[4001],b[4001],c[4001],d[4001];
int t,ans=0;
cin>>t;
for(int i=0; i<t; i++){
cin>>a[i]>>b[i]>>c[i]>>d[i];
}
for(int i=0; i<t; i++){
for(int j=0; j<t; j++){
int m=a[i]+b[j];
ab.push_back(m);
}
}
sort(ab.begin(),ab.end());
vector<int>::iterator it1 = ab.begin();
vector<int>::iterator it2 = ab.end();
for(int i=0; i<t; i++){
for(int j=0; j<t; j++){
int sum=(c[i]+d[j])*(-1);
int x=(int)(lower_bound(it1,it2,sum)-ab.begin());
int y=(int)(upper_bound(it1,it2,sum)-ab.begin());
ans+=y-x;
}
}
cout<<ans<<endl;
return 0;
}