Description
Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.
Input
Input starts with an integer T (≤ 10), denoting the number of test cases.
Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.
Output
For each case, print the case number and the maximum distance.
Sample Input
2
4
0 1 20
1 2 30
2 3 50
5
0 2 20
2 1 10
0 3 29
0 4 50
Sample Output
Case 1: 100
Case 2: 80
解体思路:是一道求树的直径的模板题.有结论,树的直径为(s,t),即树中相距最远的两结点之间地距离。从树中任意一点u出发,那么它到达的最远距离的点一定是s或t。然后从最远点出发,寻找下一个最远点,就能求出树的直径了。
代码如下:
#include<stdio.h>
#include<string.h>
#include<queue>
#define LL __int64
using namespace std;
int head[30010];
int vist[30010];
LL dfn[30010];
int node;
LL ans;
int num;
struct stu{
int t,ne,c;
}edge[60010];
void inin(){
num=0;
memset(head,-1,sizeof(head));
}
void add(int a,int b,int c){
stu E={b,head[a],c};
edge[num]=E;
head[a]=num++;
}
void bfs(int sx){//注意与SPFA的区别
ans=0;
queue<int>q;
memset(vist,0,sizeof(vist));
memset(dfn,0,sizeof(dfn));
vist[sx]=1;
q.push(sx);
while(!q.empty()){
int v=q.front();
q.pop();
for(int i=head[v];i!=-1;i=edge[i].ne){
int w=edge[i].t;
if(!vist[w]&&dfn[w]<dfn[v]+edge[i].c){
dfn[w]=dfn[v]+edge[i].c;
if(dfn[w]>ans){
ans=dfn[w];
node=w;
}
vist[w]=1;
q.push(w);
}
}
}
}
int main(){
int n,t,a,b,c,i,cas;
cas=1;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
inin();
for(i=1;i<n;i++){
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}
bfs(0);
bfs(node);
printf("Case %d: %lld\n",cas++,ans);
}
return 0;
}