/*这是学长给我讲的没有条件的全排列,这个模板很适用,在遇到需要根据条件进行排列的题目时,只要将模板稍作改动就行了*/
#include <cstdio>
#include <cstring>
int n,m,a[10],arr[10]={3,4,5,6},mark[10];
void dfs(int v){
if(v >= n){
for(int i = 0;i < n;i++)
printf("%d ",a[i]);
printf("\n");
return ;
}
for(int i = 0; i< n;i++){
if(!mark[i]){
mark[i] = 1;
a[v] = arr[i];
dfs(v+1);
mark[i] = 0;
}
}
}
int main(){
while(scanf("%d",&n)==1){
memset(mark,0,sizeof(mark));
dfs(0);
}
}
例题:hdu--Lotto
Problem Description
In the German Lotto you have to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k > 6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].
Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
Input
The input will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.
Output
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.
Sample Input
7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0
Sample Output
1 2 3 4 5 6 1 2 3 4 5 7 1 2 3 4 6 7 1 2 3 5 6 7 1 2 4 5 6 7 1 3 4 5 6 7 2 3 4 5 6 7 1 2 3 5 8 13 1 2 3 5 8 21 1 2 3 5 8 34 1 2 3 5 13 21 1 2 3 5 13 34 1 2 3 5 21 34 1 2 3 8 13 21 1 2 3 8 13 34 1 2 3 8 21 34 1 2 3 13 21 34 1 2 5 8 13 21 1 2 5 8 13 34 1 2 5 8 21 34 1 2 5 13 21 34 1 2 8 13 21 34 1 3 5 8 13 21 1 3 5 8 13 34 1 3 5 8 21 34 1 3 5 13 21 34 1 3 8 13 21 34 1 5 8 13 21 34 2 3 5 8 13 21 2 3 5 8 13 34 2 3 5 8 21 34 2 3 5 13 21 34 2 3 8 13 21 34 2 5 8 13 21 34 3 5 8 13 21 34法一: 较麻烦代码如下:#include<stdio.h> #include<string.h> int arr[55]; int mark[55]; int a[10]; int n; int sum; int flag; int head[55]; void dsf(int v) { int i,j; int k; if(v==6) { for(i=0;i<5;i++) printf("%d ",a[i]); printf("%d\n",a[i]); return; } for(i=0;i<n;i++) { if(arr[i]>a[v-1]&&mark[i]==0) { mark[i]=1; a[v]=arr[i]; dsf(v+1); mark[i]=0; } } } int main() { int m,i,head; while(scanf("%d",&n)!=EOF) { if(n==0)break; for(i=0;i<n;i++) scanf("%d",&arr[i]); for(i=0;i<n-5;i++) { a[0]=arr[i]; memset(mark,0,sizeof(mark)); mark[i]=1; dsf(1); } printf("\n"); } return 0; }
法二:#include<stdio.h> #include<string.h> int m[50],k,n[7]; void dfs(int top,int tot){ if(tot>=6){ for(int i=0;i<6;i++){ if(i)printf(" "); printf("%d",n[i]); } puts(""); return; } for(int i=top;i<k;i++){ n[tot]=m[i]; dfs(i+1,tot+1);//从当前的下一个开始查找,因为数组本身有序 } return; } int main(){int flot=0; while(~scanf("%d",&k),k){ for(int i=0;i<k;i++)scanf("%d",&m[i]); if(flot++)puts(""); dfs(0,0); } return 0; }