Longest Ordered Subsequence

本文介绍了一种求解最长递增子序列问题的经典算法实现,通过动态规划的方法找到给定序列中最长递增子序列的长度。示例中使用了一个包含7个元素的序列进行说明,并提供了一份完整的C++代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence (  a1a2, ...,  aN) be any sequence (  ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4

题目要求最长递增子序列,需要注意不能相等, 然后直接用模板就行了。

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int N = 1000 + 10;
int a[N], dp[N];
int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        int ans = -1;
        for(int i = 1; i <= n; ++ i)
        {
            scanf("%d", &a[i]);
        }
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; ++ i)
        {
            dp[i] = 1;
            for(int j = 1; j < i; ++ j)
            {
                if(a[j] < a[i])
                {
                    dp[i] = max(dp[i], dp[j]+1);
                }
            }
            ans = max(ans, dp[i]);
        }
        printf("%d\n", ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值