Nightmare
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5475 Accepted Submission(s): 2725
Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.
Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.
Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.
Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
Sample Input
33 32 1 11 1 01 1 34 82 1 1 0 1 1 1 01 0 4 1 1 0 4 11 0 0 0 0 0 0 11 1 1 4 1 1 1 35 81 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
Sample Output
4 -1 13
题意:一个迷宫,起始炸弹引爆时间给定为6。2表示起点,3表示终点。1表示可以走,0表示不能走。4表示炸弹引爆时间重新置为6。一个人背着炸弹从起点出发。问他是否在炸弹爆炸前走出迷宫。如果可以,输出他所需要的最短时间,如果不行,输出-1。
规则:1、如果刚好走到3,炸弹引爆时间变为0,则算走不出迷宫。
2、如果刚好走到4,准备reset引爆时间。但是走到该点时引爆时间刚好变为0,则不能重新设置。
3、每一个4都可以走多次,只要他需要。
思路:bfs搜索,第一个满足情况的就是答案了,唯一需要注意的就是vis数组标记的不是1不是step而是当前还有多少秒爆炸,然后维护vis的值
下面贴出代码
#include <stdio.h>
#include <queue>
using namespace std;
struct node
{int x,y,time,step;};
int turn[4][2]={0,1,1,0,0,-1,-1,0};
int main(){
int N,row,col,i,j;
scanf("%d",&N);
while(N--){
queue<node> q;
node start,temp;
while(!q.empty())//清空
q.pop();
int map[10][10]={},vis[10][10]={0};
scanf("%d %d",&row,&col);
for(i=0;i<row;i++)
for(j=0;j<col;j++){
scanf("%d",&map[i][j]);
if(map[i][j]==2){
start.x=i;
start.y=j;
start.time=6;
start.step=1;
vis[start.x][start.y]=1;
q.push(start);
}
}
while(!q.empty()){
start = q.front();
if(map[start.x][start.y]==3&&start.time>0)break;
q.pop();
for(i=0;i<4;i++){
temp.x=turn[i][0]+start.x;
temp.y=turn[i][1]+start.y;
temp.step=start.step+1;
temp.time=start.time-1;
if(temp.time>0&&(map[temp.x][temp.y]==1||map[temp.x][temp.y]==3)&&temp.x>=0&&temp.y>=0&&temp.x<row&&temp.y<col&&((temp.time>vis[temp.x][temp.y]&&vis[temp.x][temp.y]!=0)||vis[temp.x][temp.y]==0)){
vis[temp.x][temp.y]=temp.time;
q.push(temp);
}
if(temp.time>0&&map[temp.x][temp.y]==4&&temp.x>=0&&temp.y>=0&&temp.x<row&&temp.y<col&&((temp.time>vis[temp.x][temp.y]&&vis[temp.x][temp.y]!=0)||vis[temp.x][temp.y]==0)){
vis[temp.x][temp.y]=temp.time;
temp.time=6;
q.push(temp);
}
}
}
if(!q.empty())
printf("%d\n",q.front().step-1);
else
printf("-1\n");
}
}