zju 2212优先队列

Argus

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: ��Every five minutes, retrieve the maximum temperature over the past five minutes.��
Query-2: ��Return the average temperature measured on each floor over the past 10 minutes.��

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 <Period <= 3000) is the interval between two consecutive returns of the result. AfterPeriod seconds of register, the result will be returned for the first time, and after that, the result will be returned everyPeriod seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have differentQ_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order ofQ_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of ��#��.

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

SampleOutput

2004
2005
2004
2004
2005

 

这是一道简单优先队列题目。题目的意思是查询反馈结果,每个查询有一个时间间隔,每个时间间隔之后就返回ID,之后有重新开始查询以此类推。我们可以利用优先队列(stl)帮我做排序工作。优先队列其实有两种使用方法,不管哪种我们都要重载运算符,这个是使用优先队列最核心的部分。

代码如下:

#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
struct node{
 int ID;
 int p;
 int c;
};
bool operator < (const node &a,const node &b)
{
 if(a.p == b.p)
 {
  return a.ID > b.ID;
 }
 return a.p > b.p;
};

int main()
{
    char p[10];
 int t;
 node a,temp;
 priority_queue<node>l;
 while(cin >> p)
 {
 while(strcmp(p,"#"))
 {
  cin >> a.ID;
  cin >> a.p;
  a.c = a.p;
  l.push(a);
  cin >> p;
 }
 cin >> t;
 while(t)
 {
    temp = l.top();
    l.pop();
    cout << temp.ID << endl;
    temp.p += temp.c;
    l.push(temp);
    t--;
   }
 }
 return 0;
}
      



 

 

内容概要:本文深入探讨了多种高级格兰杰因果检验方法,包括非线性格兰杰因果检验、分位数格兰杰因果检验、混频格兰杰因果检验以及频域因果检验。每种方法都有其独特之处,适用于不同类型的时间序列数据。非线性格兰杰因果检验分为非参数方法、双变量和多元检验,能够在不假设数据分布的情况下处理复杂的关系。分位数格兰杰因果检验则关注不同分位数下的因果关系,尤其适合经济数据的研究。混频格兰杰因果检验解决了不同频率数据之间的因果关系分析问题,而频域因果检验则专注于不同频率成分下的因果关系。文中还提供了具体的Python和R代码示例,帮助读者理解和应用这些方法。 适合人群:从事时间序列分析、经济学、金融学等领域研究的专业人士,尤其是对非线性因果关系感兴趣的学者和技术人员。 使用场景及目标:①研究复杂非线性时间序列数据中的因果关系;②分析不同分位数下的经济变量因果关系;③处理不同频率数据的因果关系;④识别特定频率成分下的因果关系。通过这些方法,研究人员可以获得更全面、细致的因果关系洞察。 阅读建议:由于涉及较多数学公式和编程代码,建议读者具备一定的统计学和编程基础,特别是对时间序列分析有一定了解。同时,建议结合具体案例进行实践操作,以便更好地掌握这些方法的实际应用。
7-10 天梯赛的赛场安排分数 25 全屏浏览 切换布局 作者 陈越 单位 浙江大学 天梯赛使用 OMS 监考系统,需要将参赛队员安排到系统中的虚拟赛场里,并为每个赛场分配一位监考老师。每位监考老师需要联系自己赛场内队员对应的教练们,以便发放比赛账号。为了尽可能减少教练和监考的沟通负担,我们要求赛场的安排满足以下条件: 每位监考老师负责的赛场里,队员人数不得超过赛场规定容量 C; 每位教练需要联系的监考人数尽可能少 —— 这里假设每所参赛学校只有一位负责联系的教练,且每个赛场的监考老师都不相同。 为此我们设计了多轮次排座算法,按照尚未安排赛场的队员人数从大到小的顺序,每一轮对当前未安排的人数最多的学校进行处理。记当前待处理的学校未安排人数为 n: 如果 n≥C,则新开一个赛场,将 C 位队员安排进去。剩下的人继续按人数规模排队,等待下一轮处理; 如果 n<C,则寻找剩余空位数大于等于 n 的编号最小的赛场,将队员安排进去; 如果 n<C,且找不到任何非空的、剩余空位数大于等于 n 的赛场了,则新开一个赛场,将队员安排进去。 由于近年来天梯赛的参赛人数快速增长,2023年超过了 480 所学校 1.6 万人,所以我们必须写个程序来处理赛场安排问题。 输入格式: 输入第一行给出两个正整数 N 和 C,分别为参赛学校数量和每个赛场的规定容量,其中 0<N≤5000,10≤C≤50。随后 N 行,每行给出一个学校的缩写(为长度不超过 6 的非空小写英文字母串)和该校参赛人数(不超过 500 的正整数),其间以空格分隔。题目保证每所学校只有一条记录。 输出格式: 按照输入的顺序,对每一所参赛高校,在一行中输出学校缩写和该校需要联系的监考人数,其间以 1 空格分隔。 最后在一行中输出系统中应该开设多少个赛场。 输入样例: 10 30 zju 30 hdu 93 pku 39 hbu 42 sjtu 21 abdu 10 xjtu 36 nnu 15 hnu 168 hsnu 20 输出样例: zju 1 hdu 4 pku 2 hbu 2 sjtu 1 abdu 1 xjtu 2 nnu 1 hnu 6 hsnu 1 16
03-31
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值