Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly.
You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack.
For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000):
M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
原题网页:https://pintia.cn/problem-sets/1268384564738605056/problems/1271415149946912771
思路:模拟进栈出栈的动作,以所给需要判断的出栈序列进行循环与栈顶元素进行比较:;< 则break,判断为NO;= 出栈一次,continue; > 持续进栈直到相等,然后判断当前栈的size是否大于栈的允许容量,大于则break否则出栈一次;循环结束后,如果栈为空,则YES,否则NO。
代码如下:
#include <stdio.h>
#include <malloc.h>
#define MaxSize 1000
typedef int ElemType;
typedef struct
{
ElemType data[MaxSize];
int top;
} SqStack;
void InitStack(SqStack *&s)
{
s = (SqStack*)malloc(sizeof(SqStack));
s->top = -1;
}
bool Push(SqStack *&s, ElemType e)
{
if (s->top == MaxSize - 1)
return false;
s->top++;
s->data[s->top] = e;
return true;
}
bool Pop(SqStack *&s)
{
if (s->top == -1)
return false;
s->data[s->top] = 0;
s->top--;
return true;
}
int main()
{
int M, N, K;
scanf("%d %d %d", &M, &N, &K);
for (int i=0; i<K; i++)
{
SqStack *s;
InitStack(s);
int num = 0;
int a[MaxSize] = {0};
for (int j=0; j<N; j++)
scanf("%d", &a[j]);
for (int j=0; j<N; j++)
{
if (s->top == -1)
Push(s, ++num);
if (s->data[s->top] > a[j])
break;
if (s->data[s->top] == a[j])
{
Pop(s);
continue;
}
while(s->data[s->top] < a[j])
Push(s, ++num);
if (s->top > M-1)
break;
else
Pop(s);
}
if (s->top == -1)
printf("YES\n");
else
printf("NO\n");
}
}