Piggy-Bank (完全背包 动态规划)

本文介绍了一种通过已知存钱罐的总重量及其内含硬币类型来估算其最低金额的方法。这是一个典型完全背包问题的应用实例,文章提供了解决方案的详细步骤,并附带AC代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.

This is impossible.


题意:不知道存钱罐里有多少钱,现在给你存的钱的总重量(可求得)及一些货币的面值和重量,让你计算出里面至少存了多少钱,如果给出的数据不能计算出,输出This is impossible.

思路:典型的完全背包问题,给出价值和重量,数量可任选。因为此题求的是最少的钱,所以用min,dp数组开始赋一个较大的值,然后模板套用。


AC代码:

#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;

int f[1000005];

int main()
{
    int t;
    int wa,wb,m;
    int n,val[505],wei[505],i,j;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&wa,&wb);
        m = wb-wa;
        scanf("%d",&n);
        for(i = 0;i<n;i++)
        scanf("%d%d",&val[i],&wei[i]);
        for(i = 0;i<=m;i++)
            f[i] = 10000000;
        f[0] = 0;   //f[0]开始是0,容量为0的时候价值为0
        for(i = 0;i<n;i++)
            for(j = wei[i];j<=m;j++)       //从i物品的重量到总重量
                f[j] = min(f[j],f[j-wei[i]]+val[i]);
        if(f[m] == 10000000)
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",f[m]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值