Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.
Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.
Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.
Input
Line 1: A single integer N
Lines 2…N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow’s characteristics
Output
Line 1: A single integer that is the minimum number of destroyed flowers
Sample Input
6
3 1
2 5
2 3
3 2
4 1
1 6
Sample Output
86
Hint
FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.
题意:
有N头牛在破坏花园,现在需要将他们赶到牛棚里,已知每头牛赶到对应的牛棚需要Ti分钟,每头牛每分钟破坏Di朵花,一次只能赶一只牛,问在将所有的牛赶到对应的牛棚后所破坏的最少花数。
思路:
将单位时间内吃花最多的牛先赶走
代码:
#include"stdio.h"
#include"string.h"
#include"algorithm"
using namespace std;
struct M
{
int t,d;
double v;
}p[100010];
bool cmp(M a,M b)
{
return a.v<b.v;
}
int main()
{
int n,i;
long long sum=0,ans=0;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d %d",&p[i].t,&p[i].d);
p[i].v=1.0*p[i].t/p[i].d;//单位时间吃花量
sum+=p[i].d;//计算没被赶走的女吃花速度
}
sort(p,p+n,cmp);
for(i=0;i<n;i++)
{
sum-=p[i].d;//每次减去当前赶走的牛的吃花量
ans+=sum*2*p[i].t;//来回一共2Ti
}
printf("%lld\n",ans);
return 0;
}