A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 … nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
题意:
你有n元钱,去银行取出来,银行里有只有固定数量的某些面值货币,用这些货币尽可能多的取出你的钱,输出取出的钱数。
先输入总钱数n,然后输入货币种类数m,随后输入m对数,表示货币数和货币面值
题解:
多种背包模板题
代码:
#include"stdio.h"
#include"string.h"
#include"algorithm"
using namespace std;
int m,n;
int dp[100010],cost[15],num[15];
void zeroonebag(int t)
{
for(int i=n;i>=t;i--)//从n开始逆序更新
dp[i]=max(dp[i],dp[i-t]+t);
}
void completebag(int t)//t面值的货币储量大于总钱数
{
for(int i=t;i<=n;i++)//更新t到总钱数n之间的dp的值,因为此时剩下的钱数可以选择此面值的货币
dp[i]=max(dp[i],dp[i-t]+t);
}
void multibag()
{
int k=1;
int count=0;
for(int i=1;i<=m;i++)//遍历每一个面值的货币
{
if(cost[i]>n)//如果单张此面值的货币就大于总钱数,则直接找下一面值
continue;
if(num[i]*cost[i]>=n)//此面值的货币储量大于总钱数
completebag(cost[i]);
else
{
k=1;
count=num[i];
while(k<count)
{
zeroonebag(k*cost[i]);
count-=k;
k*=2;//用二进制的形式进行优化
}
zeroonebag(count*cost[i]);//对二进制优化剩下的货币进行处理
}
}
}
int main()
{
while(~scanf("%d",&n))
{
scanf("%d",&m);
memset(num,0,sizeof(num));
memset(cost,0,sizeof(cost));
memset(dp,0,sizeof(dp));
for(int i=1;i<=m;i++)
scanf("%d %d",&num[i],&cost[i]);
multibag();
printf("%d\n",dp[n]);
}
}
代码2
直接进行二进制优化,使题目变成01背包问题
#include"stdio.h"
#include"string.h"
#include"algorithm"
using namespace std;
int w[100010],dp[100010];
int main()
{
int m,n;
while(~scanf("%d %d",&n,&m))
{
memset(dp,0,sizeof(dp));
int i,j,t,x,y,k=0;
for(i=0;i<m;i++)
{
scanf("%d %d",&x,&y);
t=1;
while(x>=t)
{
w[k++]=y*t;
x-=t;
t*=2;
}
w[k++]=x*y;
}
for(i=0;i<k;i++)
{
for(j=n;j>=w[i];j--)
dp[j]=max(dp[j-w[i]]+w[i],dp[j]);
}
printf("%d\n",dp[n]);
}
return 0;
}