Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.
In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.
score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x
For example,
For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.
For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.
Now you have to solve this task.
Input
Input starts with an integer T (≤ 105), denoting the number of test cases.
Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).
Output
For each case, print the case number and the summation of all the scores from a to b.
Sample Input
3
6 6
8 8
2 20
Sample Output
Case 1: 4
Case 2: 16
Case 3: 1237
题意·:给出两个数,确定一个范围,输出范围内数字的欧拉函数的平方的和。
欧拉函数:在数论,对正整数n,欧拉函数是小于或等于n的正整数中与n互质的数的数目;
欧拉函数打表:(对于没理解欧拉函数推导的我来说只能先记代码)
for(i=0;i<=5010000;i++)
a[i]=0;
a[1]=1;
for(i=2;i<=5010000;i++)
{
if(!a[i])
{
for(j=i;j<=5010000;j+=i)
{
if(!a[j])
a[j]=j;
a[j]=a[j]/i*(i-1);
}
}
}
需要特别注意的是,打表的数组要用unsigned long long定义,直接用long long会爆,前者是20位,后者是19位。
代码:
#include"stdio.h"
unsigned long long a[5100000];//注意类型
void init()
{
int i,j;
for(i=0;i<=5010000;i++)
a[i]=0;
a[1]=1;
for(i=2;i<=5010000;i++)
{
if(!a[i])
{
for(j=i;j<=5010000;j+=i)
{
if(!a[j])
a[j]=j;
a[j]=a[j]/i*(i-1);
}
}
}
for(i=2;i<=5010000;i++)//前缀和,注意是平方的和
a[i]=a[i]*a[i]+a[i-1];
}
int main()
{
init();
int t,k=1;
scanf("%d",&t);
while(t--)
{
int m,n;
scanf("%d %d",&m,&n);
printf("Case %d: %llu\n",k++,a[n]-a[m-1]);
}
return 0;
}