http://poj.org/problem?id=3693
Maximum repetition substring
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5542 Accepted: 1663
Description
The repetition number of a string is defined as the maximum number R such that the string can be partitioned into R same consecutive substrings. For example, the repetition number of "ababab" is 3 and "ababa" is 1.
Given a string containing lowercase letters, you are to find a substring of it with maximum repetition number.
Input
The input consists of multiple test cases. Each test case contains exactly one line, which
gives a non-empty string consisting of lowercase letters. The length of the string will not be greater than 100,000.
The last test case is followed by a line containing a '#'.
Output
For each test case, print a line containing the test case number( beginning with 1) followed by the substring of maximum repetition number. If there are multiple substrings of maximum repetition number, print the lexicographically smallest one.
Sample Input
ccabababc
daabbccaa
#
Sample Output
Case 1: ababab
Case 2: aa
Source
2008 Asia Hefei Regional Contest Online by USTC
解析:
题意:
求重复次数最多的连续重复子串。
思路:后缀数组+RMQ
1,建立后缀数组,求rank[maxn],height[rank],sa[maxn],利用height数组初始化RMQ
2,枚举循环节,计算相邻循环区间的最短公共前缀(RMQ),更新循环节个数,并记录循环节个数
3.按照字典序枚举循环节所在的序列,如果找到则记录始位置,退出循环。
PS:看了题解还视觉得有很多坑。RMQ里也有好多坑
参考自:http://blog.youkuaiyun.com/acm_cxlove/article/details/7941205
以下是cxlove的思路详解:
题目:给出一个串,求重复次数最多的连续重复子串
在后缀数组神文中也这题的题解。
比较容易理解的部分就是枚举长度为L,然后看长度为L的字符串最多连续出现几次。
既然长度为L的串重复出现,那么str[0],str[l],str[2*l]……中肯定有两个连续的出现在字符串中。
那么就枚举连续的两个,然后从这两个字符前后匹配,看最多能匹配多远。
即以str[i*l],str[i*l+l]前后匹配,这里是通过查询suffix(i*l),suffix(i*l+l)的最长公共前缀
通过rank值能找到i*l,与i*l+l的排名,我们要查询的是这段区间的height的最小值,通过RMQ预处理
达到查询为0(1)的复杂度,
设LCP长度为M, 则答案显然为M / L + 1, 但这不一定是最好的, 因为答案的首尾不一定再我们枚举的位置上. 我的解决方法是, 我们考虑M % L的值的意义, 我们可以认为是后面多了M % L个字符, 但是我们更可以想成前面少了(L - M % L)个字符! 所以我们求后缀j * L - (L - M % L)与后缀(j + 1) * L - (L - M % L)的最长公共前缀。
即把之前的区间前缀L-M%L即可。
然后把可能取到最大值的长度L保存,由于 题目要求字典序最小,通过sa数组进行枚举,取到的第一组,肯定是字典序最小的。
641 MS 11344 KB GNU C++
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=100000+10;
char s[maxn];
int sa[maxn],t1[maxn],t2[maxn],c[maxn];
int height[maxn],rank[maxn];
int min(int a,int b){return a<b? a:b;}
void init()
{
memset(rank,0,sizeof(rank));
memset(height,0,sizeof(height));
memset(sa,0,sizeof(sa));
}
void build_sa(int n,int m)//建立后缀数组
{
int i,j,p,*x=t1,*y=t2;
for(i=0;i<m;i++)c[i]=0;
for(i=0;i<n;i++)c[x[i]=s[i]]++;
for(i=1;i<m;i++)c[i]+=c[i-1];
for(i=n-1;i>=0;i--)sa[--c[x[i]]]=i;
for(j=1;j<=n;j<<=1)
{
p=0;
for(i=n-j;i<n;i++)y[p++]=i;
for(i=0;i<n;i++)if(sa[i]>=j)y[p++]=sa[i]-j;
for(i=0;i<m;i++)c[i]=0;
for(i=0;i<n;i++)c[x[y[i]]]++;
for(i=1;i<m;i++)c[i]+=c[i-1];
for(i=n-1;i>=0;i--)sa[--c[x[y[i]]]]=y[i];
swap(x,y);
p=1;x[sa[0]]=0;
for(i=1;i<n;i++)
x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;
if(p>=n)break;
m=p;
}
}
void getHeight(int n)//得到height数组
{
int i,j,k=0;
for(i=1;i<=n;i++)rank[sa[i]]=i;
for(i=0;i<n;i++)
{
if(k)k--;
j=sa[rank[i]-1];
while(s[i+k]==s[j+k])k++;
height[rank[i]]=k;
}
}
int d[maxn][20];
void RMQ_init(int n)
{int m=floor(log(n+0.0)/log(2.0));
for(int i=1;i<=n;i++)d[i][0]=height[i];
for(int i=1;i<=m;i++)
{
for(int j=n;j;j--)
{
d[j][i]=d[j][i-1];
if(j+(1<<(i-1))<=n)
d[j][i]=min(d[j][i],d[j+(1<<(i-1))][i-1]);
}
}
}
int RMQ(int l,int r){
int a=rank[l],b=rank[r];
if(a>b) swap(a,b);
a++;
int m=floor(log(b-a+1.0)/log(2.0));
return min(d[a][m],d[b-(1<<m)+1][m]);
}
int main()
{
int ca=0;
while(scanf("%s",s)!=EOF&&s[0]!='#')
{int i,j,k,maxv,L1,temp;
int n,cnt;
init();
n=strlen(s);
build_sa(n+1,130);
getHeight(n);
RMQ_init(n);
maxv=0;
cnt=0;
int num[maxn];
for(i=1;i<n;i++)
{
for(j=0;j+i<n;j+=i)
{
L1=RMQ(j,j+i);
temp=L1/i+1;
k=j-(i-L1%i);
if(k>=0&&L1%i)
if(RMQ(k,k+i)>=L1)
{temp++;}
if(maxv<temp)
{
maxv=temp;
cnt=0;
num[cnt++]=i;
}
else if(maxv==temp)
{
num[cnt++]=i;
}
}
}
//printf("cnt==%d\n",cnt);
int len=-1,st;
for( i=1;i<=n&&len==-1;i++){
for( j=0;j<cnt;j++){
int l=num[j];
if(RMQ(sa[i],sa[i]+l)>=(maxv-1)*l){
len=l;
st=sa[i];
break;
}
}
}
printf("Case %d: ",++ca);
for(i=st,j=0;j<len*maxv;i++,j++)
printf("%c",s[i]);
printf("\n");
}
//system("pause");
return 0;
}