【PAT甲级】1005 Spell It Right (20 分)

本文介绍了一个计算非负整数N所有位数之和并用英文单词输出的算法挑战。输入为一个不超过10^100的非负整数,输出为各数字位和的英文表示,相邻单词间有空格,末尾无多余空格。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1005 Spell It Right (20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

 妥妥的签到题,做的本渣渣信心百倍。

【翻译】:给出一个非负整数N,N的范围在0到10^100,要求计算N所有位数相加的和,并且用英文输出,行尾不可有多余空格。

#include <iostream>
#include <string>
using namespace std;
string n;
int sum = 0;
string e[] = {"zero","one","two","three","four","five"
,"six","seven","eight","nine"};
int a[1000000];
int main(){
	cin>>n;
	int len = n.length();
	for(int i = 0; i < len; i++){
		sum += n[i] - '0';
	}
	int j = 0;
	while(sum > 0){
		a[j++] = sum%10;
		sum = sum / 10;
	}
	cout<<e[a[j - 1]];
	for(int i = j - 2; i >= 0; i--){
		cout<<" "<<e[a[i]];
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值